Laser no longer fires

Machine: K40 that originally came with M2 Nano

Board: LaserBoard

Firmware: Smoothie!

Problem/ Question:

I recently installed a laser board in my K40 and at first everything worked properly with Lightburn.
Today I went to use the K40 and the laser no longer fires under control from Lightburn. It does fire with the K40 laser test button. Laser current is adjusted to 14ma. When I enter G1 X100 S1 F600 at the console the Fire status LED on the Laserboard does light up but the laser does not actually fire. I attached a multi meter to the red/black wires shown in the attached in the photo and it reads open circuit, even when the fire LED is active. I’m assuming that there must be a FET in there that should close the circuit to fire the laser and it’s blown. Please advise as to how I can get this working again.

Hi Wayne,

Thanks for the photos and test results for what you have tried up to this point.

Trace the red (L) and black (GND) wires back to the power supply and send us a clear picture of this wiring.

Try this test and report back with the results:

  • With the machine off, disconnect the L and GND wires from the LaserBoard.
  • With the laser machine on, very carefully touch these wires together and the laser should fire.
  • This replicates how the board “talks to” the LPSU, but removes the board from the equation. Be sure to turn the machine back off before proceeding with reconnecting the board.

There is also an alternate wiring configuration which we have available (as shown in the photo below):

  • Laser Fire (L) goes to “FET -”, the lowest screw terminal pin along the left edge (indicated with yellow line).
  • Ground (G / GND) goes to the board ground, the top left screw terminal right pin (indicated with black line).
  • Note: This is hooking up to the actual ground plane of the board, so there is no longer protection afforded by the opto and damage to the board could occur with any power spikes, invalid wiring, etc.

Once you do that, try inputing G1 X10 Y10 S1.0 F600 as a test into the console and let us know what happens.

Also, we received your email. We were in the process of troubleshooting to determine what the issue could be. It takes time to review and get enough information to problem solve, so we appreciate your patience while we work through this together. We noticed you placed another order. Please let us know if you still wish to proceed, in light of this response.

The red and black wires in the photo do not go anywhere, I simply added them so I could connect a multi meter to see if L is grounded when the laser is told to fire, it is not. (no continuity).
Grounding L DOES cause the laser to fire which should confirm the wiring from the board to the LPSU is correct and the LPSU is operating properly.

Entering G1 X10 Y10 S1.0 F600 from the console does cause the board to respond, the head moves to X10 Y10 and the laser status LED in the corner of the board lights but the laser never fires.

Your alternate wiring instructions are a bit vague and when I tried to do what I thought you were asking the board does not work at all, it doesn’t even connect via USB so I put everything back to the original configuration and everything is working again.

As far as I’m concerned the first step you asked me to perform (connecting L to ground fires the laser) CONFIRMS that there is nothing wrong with the wiring, the LPSU works properly and the board has failed. Please arrange for a replacement board or if this can’t be handled under warranty simply go ahead and process the order placed last night as I feel further troubleshooting will only delay getting my laser operational again and I NEED it operational again ASAP.

Hi Wayne,

We’re actively trying to help you, and responding to you as quickly as we can. You are changing things before we’ve had time to review and respond and ultimately we don’t have enough information at this time.

Rushing through things is how irrecoverable mistakes are made, which breaks expensive things. This is why we need to get information from you about your setup, analyze it, and let you know exactly what to do next.

The component on the LaserBoard that fires the laser by default is a small opto isolator, which appears to no longer be working for you. There is also a very large FET driven by the same pwm channel, and that is what we are trying to get you to switch over to by switching to the output labeled “Laser Diode Out”. The name written on the board for this screw terminal is simply that, the name. We’re telling you what’s actually driving it. This is not an experiment, it is a known solution for cases like this.

We’d like to see clear pictures how you attempted to do the proposed wiring to the LPSU so that we can help you. You can mock it up without turning anything on, or show it any number of other ways. The goal is to connect one wire to L on the LPSU, and the other way to Ground on the LPSU, and the other ends of those wires would go to the board as shown in the picture previously.

It’s about to be a holiday weekend, so you can either work with us so that we can get you up and running quickly, or you can wait a significantly longer time while your new order is in transit to you. The decision is up to you.

Based on the information you provided I connected a red wire from the laser diode output and connected it to the LPSU L connector (far right). I could not fit the red wire along side the green wire from the laser connector so i left the green wire disconnected. I then connected a black wire from the - power connector you indicated to the LPSU Gnd connector, located 2 positions to the left of the L connector. Since there were already multiple wires in this spot I disconnected the white wire from the laser connector and replaced it with the black wire from the - power connector you indicated When I enter G1 X10 Y10 S1.0 F600 the head moves, the Laser status LED lights but the laser doesn’t fire.

While this may be helpful as a temporary work around I don’t consider this a permanent solution so please process my order for a replacement board ASAP.

I believe the red and black wires are going to the correct locations on the LPSU.

You should definitely remove the large power plug from the LaserBoard as part of this process - nothing from there is needed.

You can also remove the other wires with the ferrule pins from the L and Gnd positions on the LPSU - only the red and black wires from the LPSU should be needed at those positions.

At this point the laser should fire using the same test.

Again, I hope you see that we are trying to help get you up and running as quickly as possible.

We are also not declining warranty coverage, however that would involve getting your board back first for inspection and repair/ replacement as appropriate, and I understand that you are on a tight timeline.

To confirm, we will ship your paid order as it stands, as soon as we can.

Success. I disconnected the large plug and re-seated all the connections and now the laser fires when I enter G1 X10 Y10 S1.0 F600.

Hopefully this will work until the new board arrives and I can make some progress on my project.

If you provide return instructions, I’ll return this board for evaluation once the new board arrives and hopefully it can be repaired so I can have it as a spare.

Thanks for your help.

One last question. When the new board arrive and I wish to use the opto, do I still only need the L and Gnd wires of that interface or would it be better simply to reconnect the laser power connector ?

Only the L- and GND wires need to be connected - you can leave the +24V and +5V lines completely disconnected.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.