Laser head wont move

Machine: blue and white k40 with m2nano board

Board: laserboard with smoothie


Problem/ Question:
i have the laser board installed and hooked up correctly wires are all installed and working.

i have all the correct leds lit up lightburn recognizes the laser and even sends commands to the laser but the laser does not move at all not even at start up. when you power on the machine the steppers do recieve power and lock up but nothing eles. i have removed the board and reinstalled the m2 nano board and the laser works just fine with k40 whisper no issues at all.

im attaching a video

also running windows 10

im getting really fed up with this board everyone seems to think very highly of this board but i have had it since before christmas, and have not been able to do a damn thing with it.

Hi Matt,

Thanks for your patience while we caught up with support inquiries, and for providing the video - it does offer some clues.

Just so we can be on the same page about what happened, in your last post from a few weeks ago you did receive some responses and someone asked you for the usual pics of the board, wiring, etc. As far as I was concerned we were waiting for you to post those this whole time. A simple “I have already posted pics in this other topic, link” would have everything needed to move the inquiry further along.

Anyways, now I know we have a few pics of your setup here: Glcd stays blue and annoying beep is constant help!

Regarding your issue, I think we can trace it to one of the following things:

  1. Please put the memory card in the computer and verify that there is a firmware file and a config file on the card. A screenshot of the contents of the memory card can help us confirm that everything is correct.
  1. Follow this guide. Start with turning off auto-homing as it shows in LightBurn as it shows at the top.
    Put the head in the middle of the machine as you had in the video.
    Now when you turn on the machine, the motors/ head should NOT lock.
    You can try to use the jog buttons in LightBurn’s move tab, and try to move the head left/ right and foward/ back.

  2. Finally, follow the rest of the guide to actually test the homing switches in LightBurn.

Please let us know the results of all the items above.

Again, it’s been a crazy time since the holidays and we are working to get back to normal. Thank you for your understanding. I wrote a full update here: End of February Status Update

Hi thank you for your response i’m in great need to get this laser going i have a lot of projects piling up.
here is another video i followed your questions also i have tried deleting the memory card and doing a fresh install of the software from your download and that has made no difference. i feel as though the everything is working like it is supposed to but the signal to the stepper motors isn’t leaving the board maybe a bad connection on the board itself might cause this? not sure also not sure if the Glcd screen having the constant blue screen and load beep have something to do with it. but i can live without the screen for now i just need this working so i can get to work and then figure out the camera which i haven’t tried yet

Matt, thanks for the video. I saw a few things…

First, if you have a GLCD screen connected, power everything off and disconnect it so we can isolate any issues that might be causing.

Next, it looks like your SD card has firmware.bin on it, but after the firmware flashes correctly the file should be renamed to FIRMWARE.CUR so perhaps your firmware did not flash properly.

If you read the section on this page titled Flashing Firmware it should help you check that the firmware gets properly flashed. (You mentioned the LEDs appear to be showing normal operation, but by default a new board will show that.)


Here’s an example of the output you should see if you type M119. The board will provide feedback to the console.

You should probably grab the latest version of the firmware as well. It looks like the dates on yours are 2018. (I’m not sure if they are that old or if the SD card has a weird date issue.)

Once you have confirmed that the firmware flashed correctly and the file has changed from firmware.bin to FIRMWARE.CUR give it a try again and see what happens. (We might still need to edit the config.txt file but getting the firmware working properly is the first step.)

ok thanks for a quick response. i have now tried new firmware several times with 4 different sd cards and none will change the file to .cur i have the lcd disconnected as well.

when i try to flash the new firmware the l1-l4 lights go off then just come on like normal not counting binary like the articles says could this be a bootloader issue? thanks -Matt

Did you reformat the SD card(s) to wipe them clean? Format as FAT32, then copy the firmware.bin and config,txt files to the card. SD cards can be a bit fickle and some just don’t work properly with some hardware.

OK so we are making progress!!!
i did need to reformat the SD card (windows 10 wouldn’t allow FAT32 so had to google it) and got that done flashed the new cluster firmware and the head finally moves! but the homing failed so i did the end stop test and both endstops are working correctly but the head move to the front left and crashes and tries to keep going in the Y axis

i have checked the setup in light burn and have the table setup as X300mm and Y200mm origin set to front left ill link another video showing everything.

thanks for all the help it is very much appreciated!


Progress is good! Can you confirm that you now have FIRMWARE.CUR on the SD card along with your config.txt file? Also, are you using a good quality USB cable? (Sometimes the one you get with your laser cutter is low-quality and has connection issues.)

It looks like you endstops are working right, so let’s try to confirm everything is moving properly.

Power off the machine, place the head in the center of the machine, and power it on, but don’t press the Home button in LightBurn, and don’t jog the head. Does an error show in the console? We should not be seeing an error if the head is sitting idle.

Next, take a look at the PLAY LED on the board. It will be in the top right corner of the board near the buttons (when looking at the board right side up). It should normally be on solid when nothing is happening, and will turn off when the head moves, and will flash if there is an alarm state. Is it solid, off, or flashing?

Finally, test the left, right, up down jog buttons in LightBurn. Does the head move in the correct direction with each button click?

yes i have .cur and config on the sd card im using a brand new usb cable. there is no error in console, the play LED is solid, the head moves in the x direction and im not sure if its the jolt of moving or what but slightly move in the y when moved left or right. but it does not work when pressing the y direction. the console states that the stream has completed and shows no error even in the y direction also the movement is set to move 100mm at a time but really only move about 10.

Matt, glad to hear you’ve got the FIRMWARE.CUR and config.txt file in place now, as well as a new USB cable.

Let’s check on the X direction, then the Y direction.

  1. In LightBurn click the left and right buttons to jog the X.
  • Does the head move left and right?

  • Does it move the distance you have set in LightBurn?

  • Does the Y move while X is moving?

  • Describe the result - does it move smoothly, does it move but with a grinding sound, does it stay in place and buzz, or does absolutely nothing happen?

  1. In LightBurn click the up and down buttons to jog the Y. Describe what happens.
  • Does the head move up and down?

  • Does it move the distance you have set in LightBurn?

  • Does the X move while Y is moving?

  • Describe the result - does it move smoothly, does it move but with a grinding sound, does it stay in place and buzz, or does absolutely nothing happen?

If you want to provide a video that shows what happens, that might also be useful, but answering the above questions is what we need first.

Since, you’ve been taking the board in and out regularly, please provide us the latest pic of all the wiring going to the board. We are asking for this because we want to make sure everything is properly in place; the ribbon cable, the Y motor cable, the endstops, etc.

Once we have photos showing all the wiring and answers to the questions above, we can try to diagnose the current issue.

ok i made another video hoping it will help the alarm is new

Matt, thanks for the video. I noticed that you seem to have the Y motor cable plugged into the X socket on the LaserBoard. Power down the board, unplug the Y motor cable from the X socket, then plug it into the Y socket (they are labeled) and hopefully you’ll see both your motors moving properly.

thanks so much for all the help. the head is now homing and moving with the arrows the way it should i don’t have time to do a test cut yet but i will this weekend and i’m pretty excited about it. i will definitely let you all know if it is working properly.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.