Laser head movement speed adjustment

Machine: K40

Board: C3D Laser board

Firmware: Smoothie

Problem/ Question: Home and beginning of cut feed rate.

I am trying to configure the movement of the XY when you press the home button and when you press play.

Going to home is too slow and starting a job is too fast.

I am looking at the configuration file and was wondering if I get this right before I make changes.

Are these the settings when pressing the home button?

alpha_fast_homing_rate_mm_s 50 # feedrates in mm/second
beta_fast_homing_rate_mm_s 50 # "
gamma_fast_homing_rate_mm_s 4 # "
alpha_slow_homing_rate_mm_s 25 # "
beta_slow_homing_rate_mm_s 25 # "
gamma_slow_homing_rate_mm_s 2 # "

Is this the setting when pressing the PLAY button (and movement between cuts etc.)?

default_feed_rate 4000 # Default rate ( mm/minute ) for G1/G2/G3 moves

It’s a bit too fast and I want to slow it down probably by half the speed.

TIA

The first thing you discuss is the travel speed (ie: when the head moves in between while not firing the laser). This is the default_seek_rate at the top of the config file. You can bring this down to 18000 or even 9000 depending on things. We did set it quite fast.

The fast homing rates are the ones that control the initial move speed when you press the home button.
Leave the slow homing rates alone - they are what control the speed when the head hits the switches, then backs off, and touches them again slowly for precision.
Alpha is X, Beta is Y.

Thanks. That’s exactly what I did.

Lowered the first one to 14000 and left the homing speed as it is.

How do I adjust these same settings in GRBL-LPC?

The latest LightBurn version can change them via Edit --> Machine Settings

A more thorough explanation of GRBL settings can be found here: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration