Laser fires when powered on laser board

I installed a pot and amp meter and tossed the digital control. The pot works great and the test fire switch shows. The glcd works and goes through the menus. The laser fires if the fire pin on the laser board is connected. The wire is green in the photos. The supply fire pin shows 4v with the green wire disconnected. It goes to 0v when the green wire is connected.


The pin next to the fire pin on the supply is empty on the web site I followed. There is an unknown yellow wire in my setup. I used a scope in case it was pwm and it is dead 0v.

Yeah you need to hook up just L and Gnd to the board, and where the yellow wire is, is not Gnd. That’s empty. Gnd is 1 up. Triple check this - read both sides of the board.

I removed the yellow wire and it is still bad. I have no idea why you wanted mer to check thr wiring. The wiring worked fine using the nano board and it worked fine with your board before I changed from digital to analog. I wired the pot wrong at first and may have broken something. Is there a schematic available for the laser board.

I see you are at a rep rap. Have fun. I’m having fun. I will retrace my steps to try and figure out what I did.

Ah, there is a white wire in that plug at the proper position, I just didn’t see it at first glance and thought you were running without a ground wire for laser fire. My mistake.

This should help:

The yellow wire position is not connected to anything on LaserBoard.

Are you testing by sending a command such as G1 X10 S0.6 F600 ?


ERRF was a week ago, but it has still been busy since I got back - in addition to work, this weekend I installed the latest OpenPilot hardware in my car (new hardware = stealth install !) and have been working on building the RailCore 3D Printer kit I picked up while down at ERRF.

You sound a lot like me. The more projects the better. The laser is mainly setup fun and I have no clue what I’ll do with it. :slight_smile: I looked at that 3d printer. Laser people know 3 point alignment of planes is the way to go. A 4th point can warp the plane. The three point leveling of that printer is something I wanted to do. Another project. Everything on my laser works except the L pin. What drives it? Open drain? I don’t understand the opto-isolator comment in your link. Is the isolator in the laser?

There’s an opto on the board, there’s another opto in the LPSU. There’s multiple other ways to fire various kinds of lasers on the board.

What I care about first is whether you can send the command and get the red LASER FIRE STATUS LED in the corner of the board to turn on when that happens. If not, try again without the large power plug connected to the board.

Thanks. I rearranged everything so I can view the leds and do the plugs without standing on my head. I don’t have the PC hooked up so I used the laser test fire menu and the fire led lights. About the isolator. If the output is a photo diode I think I figured out the problem. The fire and ground are backwards. The fire pin on the supply is 4v and the diagram on the web says it should be -4v. Is it supposed to be minus 4v?

Thanks for the reply.

Ignore the previous post. The otpo thing sent me offtrack. I got it all installed in the proper place now and hooked to my PC.

G1 X10 S0.6 F600
Moves to X10 , but no fire LED. I thought I saw the LED before, but not sure.

I should mention that I switched from digital to a pot and amp meter. The digital quit working so maybe something else broke. Power supply?

I moved the laser over by my new pc. X86 linux ubuntu. I downloaded lightburn and did the intro video. It works great. I did the G1 command and the red fire led came on while it moved to X10. What’s the part number for the isolator? Lightburn is amazing. :slight_smile:

Yeah -4v at the LPSU depending on which way you measure is not a problem.

So you get a red light. Keep the 4 pin power plug disconnected. Now grab a meter and put into continuity mode. Negative lead on G and Positive lead on L (positions 2 and 4 on the 4 pin screw terminal next to the power plug which has the same connections). Run the same G1 command as before. When the red light turns on, you won’t get a full on beep from the meter, but you should have some amount of continuity something showing.
If not, bad opto.

LTV-217-G
LITE-ON

I miss the days when Arrow would overnight me 2 of those for 78 cents total.

I had tried that before and it was only 14 ohms with the power off. I think it’s shorted out. I’ll lift the pins off the board to make sure there isn’t a short on the board. Digikey is ok. But there is a minimum shipping charge. You mentioned railcore and I googled. I ended up buying the kit. Delivery Wednesday.

1 Like