K40 with C3D mini smoothie config

Machine: k40

Board: c3d mini

Firmware: _Smoothie

Problem/ Question: Before installing my c3d mini, I used the stock board, inkscape and k40wisperer. When I bring a previously used svg file into my new software, LIGHTBURN, the image printed/cut is about 50% of the size. I’m using the default config file for the mini. Is there something in the config that would cause this?

I’m assuming you checked that the dimensions of the SVG are showing the expected size in LightBurn?

I did but will double check this. If I remember correctly the size was correct in lightburn. I know I can just modify the size but wanted to see if I might need to change the config.

I checked and Lightburn has the correct size but the cut/engrave is 50% smaller. E.g.- 200mm square in Lightburn is 100mm on the K40.

Thanks for verifying in LightBurn.

Next, it would be helpful for you to post some pictures of the machine, wiring, and controller so we can verify some things with your setup. That will help us help you more.

One thing to test is in the Move tab in LightBurn, Jog the machine 100mm in each direction and measure the actual traveled distance, and report back.

The solution could be as simple as doubling your steps settings in the board’s config file, but we’d like to make sure that all else is good which is why we are asking for this information first.

I jogged the machine with distance set to 100mm. To the right,down,left and up. Each time it moved 50mm.

I see the issue. You have DRV8825 Drivers which run 32 microsteps with the default C3D Mini jumper configuration.

In your config you can double your step value for the Alpha and Beta Axis and that should correct your issues.

Thanks Joe, I doubled the step values for both X and Y. This did correct the issue. Thanks for working on this with me. I figured it was something simple, but didn’t know where to look.

1 Like

I can start a new thread if necessary, but I still have an issue with the C3D mini and LightBurn. It appears like it is loosing the Y position. I tried to make sure there wasn’t anything binding, cleaned my rails, tightened all belts (but I don’t think they were loose). I slowed down my speed and nothing seemed to work. So I decided to reinstall my M2 nano board. With this installed and running the same speed as before, I had no issues. I’ve cut/engraved a couple different things and they were perfect. So based on this I think my mechanics are not the issue and it is something either with my board/setup or the LightBurn configuration.


The image on the left was done with the stock m2 nano board and K40 Whisperer/Inkscape. The image on the right was done with the C3D mini/LightBurn.

How fast were you trying to raster? Smoothie is only currently good to about 100mm/s.

I was at 20mm/s for the raster and 7mm/s for the cut which also was not right.

Can you provide a copy of your configuration? Did you change any settings besides stepping?

config.txt (25.3 KB)
I did not change anything besides the stepping.

I do see difference from original stock, but there were some variables with those boards. Would it be possible for you to send a video of how it’s behaving?

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.