K40 Upgraded board to Cohesion, Y axis is not moving and not homing

Machine: K40

Board: Cohesion

Firmware: Smoothie

Problem/ Question: I installed the new board. However it laser only goes left and right. It does not move forward or backwards and i am not sure why. I am new to this and lost as to why it is not moving. When I originally set it up i had placed the pin into the X spot on the board. It was moving forward and back but was struggling to move left and right. I am able to move both with my hands. Once i looked back at the installation of the board I realized i had it in the wrong spot and should have been in the Y. But since correcting that it does not move forward and back, just left and right. I will be attaching photos in a bit for the set up.

Tried to upload photos but it says new users cant upload images

Hi Dayna,

Welcome to the forum!

I have upgraded your trust level so that you can now upload pictures. The photos we need to see will be of the machine, board, other electrical components, and wiring.

1 Like

Thank you! Uploading momentarily

@Starla

you didn’t happen to have the board powered up when you moved that stepper cable?

Hi Dayna,

Thank you for the photos.

First, let’s check your Device Origin and confirm that you have it set to the front left.

Put the head in center of your machine. Use the move buttons in LightBurn to jog left, right, up (moves the head toward the rear of the machine), and down (moves the head towards the front of the machine). What happens if you hit the “Home” button? If you can, post a video to YouTube and share the link here with the results.

@Starla so I dont know what changed but its moving now. But when I did the homing it went to the back left corner. When I hit got to origin it goes to the front left corner.

this is more than likely correct. switches are in the top left. origin aka 0,0 is bottom left.

Machine: K40

Board: cohesion

Firmware: smoothie

Problem/ Question: well 2 issues

  1. Homing the laser it goes to the back left corner. I use lightburn. When I hit origin it goes to the front left corner. Are they both supposed to be in the same spot?
  2. I tried to engrave 3mm wood and the laser did not seem to fire. I will provide video but unsure how to upload

Hi Dayna,

I’m glad you got it moving properly! I merged your other topic here to track everything together, as this is related.

This movement is expected behavior. Origin is (0,0) like a Cartesian graph, it’s in the lower left.

image

You can set LightBurn to start at different origin points or positions and even have it finish in the location you want versus going back to the origin point. More information: Coordinates and Job Origin

For your second question, you can post a video to YouTube and share the link here we can better understand the issue you are having.

Is the E-Stop button disengaged before you send the job to the laser? Most machines have some sort of switch(es) which must be toggled to allow the laser to fire. Some machines have additional safety features. Are all of the buttons and switches set properly?

The number on your digital panel looks pretty low. The laser output has to be set at or above the minimal threshold to get the laser to fire. This will typically be 10-15% of the tube wattage (which may vary from the label on the tube). Ex: For a 40W tube, this would be >= 4-6 mA. Lasers vary, but this would probably be closer to a digital value of 16-20. Try increasing it. You can safely set it up to 15mA for a 40W (or around 50 on the digital panel).

Keep in mind, the stock configuration has the laser default power set to 80% to prevent overdriving the tube, so you will have to do some trial and error to dial in your machine settings.

@Starla

Thank you for those details. I am attaching the link. In the beginning of the video I am pressing the test fire button to see what the meter does. As you see it did move but then I run a job and the meter barely moves and of course doesn’t fire. https://youtu.be/yAOG6cvtViA

Thanks, Dayna.

Can you provide screenshots (no cell phone pics, please) of the entire LightBurn window and the layer settings for the file you are working with?

If you are running your machine too fast or the power too low, sometimes it will fail to trigger the laser enough to provide any discernible output.

  1. In LightBurn, view the Cuts / Layers panel and select the layer you want to test. Each machine will vary, so test different values to dial in your laser.

  2. Review your Speed and Power settings.
    a. Try decreasing the speed value.
    b. Try increasing the power max on the layer.

    image

@Starla

Hi Dayna,

Thank you for your patience while we get caught up on posts from over the weekend. The LightBurn settings look good.

Run the following test and let us know what happens (pictures or video will be helpful):

  1. Type the following GCode in the LightBurn console to test. Ex: G1 X10 S0.8 F600

  2. Hit the Enter key to send.

    image

  3. The head should move while firing. The red status LED “Laser Fire Status” in the bottom left corner of the board should turn on (below the laser power and laser diode out screw terminals on the left side of the board).

    image

Please report back with the answers to the questions and explain what steps you took.

  • Is the board showing “Normal Operation Mode”?
  • Is the SD card being read properly? Please provide a screenshot of the card contents.
  • Is the laser head moving while firing with the LED lighting up?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.