K40 Laser fires at power on after installing C3D board

Machine: K40 with Digital Display and M2 Nano Board

Board: C3D LaserBoard

Firmware: I have a new board and I’m using what it came with.

Problem: Brand new K40 with digital display and M2 Nano board. I did a quick test of the stock setup and the machine powers up, auto homes to the top left, and I am able to test fire the laser.

I then installed the C3D board as described on the website by doing the following:

  • Hooked up X and Y connections
  • Plugged in 4 pin, which has G, L, 5V, and 24V
  • Plugged in endstop connector
  • Connected DC into board
  • Connected USB into board
  • Plugged in SD card the board came with
  • Plugged AC power supply for board into outlet.

Had K40, water pump, and C3D power supply plugged into a 3-way extension cord.

LED’s lit up as described on the website for normal operation.

Hooked the USB to my Mac with Lightburn. I was able to jog the X and Y and send the laser to home. Prepared a test job by drawing simple squares. 1 in each corner and 1 in the center. When I tried to run the job I got the message saying there was an issue with the USB (I’m sorry I don’t remember the exact wording). I tried to unplug the USB and reconnect it and tried to run the job a few more times with the same result.

GFI outlet tripped. I reset the outlet and have moved the water pump and K40 power to an outlet and the LaserBoard to a different outlet.

When I power on the laser it starts firing immediately. Only way to stop this is to power off the machine or turn the power down to 0. I was able to jog the X and Y in Lightburn and send it back to home.

What’s interesting also is once I hook my computer up and have the board powered on I can hear a hissing from the laser tube. It continues even after I turn the machine off. It only stops if I unplug the DC cord from the board.

LEDs still light up as normal operation. No visible damage to board on front or back.

What am I missing here?

Please help me! I am at a loss and am confused what is happening.

I hooked up the M2 Nano board and it powers up normally. Homes to top left and I am able to test fire laser, but it does NOT begin firing on its own.

Red and black going into the 4 pin on the c3d board are for the red dot that came installed on the laser.

When I first swapped out the Nano board for the C3D I noticed a hissing sound at power on - at the time I thought this may have been the laser power supply. I have since discovered that this was the sound of the laser tube firing. It seems that from the beginning of installing the C3D board, the laser fires once the machine is powered on.

Laser fires at power on as long as the 4 pin LV connector is plugged into the LPS and the C3D. This happens regardless if the C3D is powered on or not.

Here is a photo of some tests I did to check for voltage at the laser fire pin on the C3D board as well as a continuity test checking for ground.

Unit was powered on for all 4 tests.

Laser began firing automatically for tests M1 and M3

—————

Here is the config file info for the laser module (all stock the way the SC card shipped):

Laser Module Configuration

laser_module_enable
true
Whether to activate the laser module at all. All configuration is ignored if false.

laser_module_pin
2.5
this pin will be PWMed to control the laser. Only P2.0 - P2.5, P1.18, P1.20, P1.21, P1.23, P1.24, P1.26, P3.25, P3.26
can be used since laser requires hardware PWM

laser_module_maximum_power
1.0
this is the maximum duty cycle that will be applied to the laser

laser_module_minimum_power
0.0
This is a value just below the minimum duty cycle that keeps the laser active without actually burning.

laser_module_default_power
0.8
This is the default laser power that will be used for cuts if a power has not been specified. The value is a scale between the maximum and minimum power levels specified above

laser_module_pwm_period
200
this sets the pwm frequency as the period in microseconds

switch.laserfire.enable
false

switch.laserfire.output_pin
2.6

switch.laserfire.output_type
digital

switch.laserfire.input_on_command
M3

switch.laserfire.input_off_command
M5

@Cohesion3D @raykholo please help

I know you must be swamped, just looking for some guidance :slight_smile:

Yes, I’m recovering from the exhaustion of trade show weekend + travel, and I also moved just before leaving for said travel, so my life (and office) is still packed away in boxes, and I’m just working off my laptop. Swamped would be putting it mildly :slight_smile:

I saw that you had a detailed thread in MakerForums, and would need time to review everything here (and skim what is there).

I completely understand! Take time to catch up!

The guys over at maker forums helped a lot in tracing the potential issue. I haven’t done any kind of modifications or fixes yet though.

Happy to provide info or pictures as needed. I know it’s a long thread and you have lots of other things on your plate currently.

Don’t worry, I’m patient!

Thanks.

I really try not to just “shoot solutions from the hip” as it usually doesn’t go well (and that’s what most Fb groups are for). But, I will work through this piece by piece, and ask you to repeat some things back to me so I can process more quickly.

This suggests power spike, blame the LPSU. These machines do this and it’s the bane of my existence.

Laser firing and opto - where are we at now?

4 pin plug connected to board - laser fires once you turn the laser on?
What about 4 pin plug disconnected from board?

Nano hooked up stock: K40 homes upon power on, laser doesn’t fire unless I hit test fire.

C3D hooked up to X, Y, ribbon endstop cable, and 4 pin LV plug hooked up: laser fires upon powering on the machine. Takes a couple seconds as the digital display turns on and sets to whatever power setting it was on.

If I unplug the 4 pin the laser does not fire at power on.

Note that the results are the same whether the C3D is powered on with the supplied power supply or not.

LED’s are lighting up as normal operation.

When I run a job in Lightburn (I’ve tried this with the K40 off as well as on, but at 0 power) the laser moves and I do get the red fire status LED

I do NOT get the red fire status LED if I am not running a job though.

Any additional info I can provide? Tests you can help me perform? Really wanting to get this issue resolved.

Thought this might be good background info

In cases like this, we have an alternate component on the board that can fire the laser, and here is info for the alternate wiring configuration:

  • Remove the large power plug from the LaserBoard. You’ll likely need some jumper wires to connect from it to the connections described below. Trace out the L and Gnd lines.
  • Laser Fire (L) goes to “FET -”, the lowest screw terminal pin along the left edge (indicated with yellow line).
  • Ground (G / GND) goes to the board ground, the top left screw terminal right pin (indicated with black line).

Alternate_Wiring

Once you do that, try inputing G1 X10 Y10 S1.0 F600 as a test into the console and let us know what happens.

Please provide pictures of the new wiring at the LaserBoard and LPSU ends, and I’m happy to take a look and advise first if you’d like.

Just to confirm, by the above do you mean to stick a wire into the L and G side of the plug at the C3D side and then run those wires over to the points you indicated?

Like this?

@Cohesion3D here are the results from the tests.

Test 1:

  • C3D wired as you instructed
  • X, Y, and endstop ribbon cable all hooked up
  • L and G going from the pins you showed into the 4 pin plug, which goes to the LPS. (24v and 5v wires not being used)
  • C3D NOT plugged into your power supply.

Laser fires upon powering on the K40.

Test 2:

  • All conditions remain the same except the C3D IS plugged into your power supply.
  • LEDs indicate normal operation when I power up the LaserBoard

Laser does NOT fire upon powering on the K40.

Now onto running the commands…

  • I hooked up to the computer
  • Powered on the C3D board
  • Powered on the K40 (does not fire at power on)
  • Laser homes and starts making a hissing noise, but the laser is not firing (I checked by turning the power up and it is not marking my material)
  • Ran the command G1 X10 Y10 S1.0 F600
  • Red fire status LED comes on while the command is executed
  • Laser head moves and fires for the duration of the command
  • I can send it back to home, but still hear the hissing

I can get the hissing to STOP if I press “Stop” in Lightburn.

  • I can move to origin then back to home
  • Run the same command and I get the same results as above.

Here is how it is wired. See above photos for more detailed tracing of wires.

It sounds like from here onward, that the board is now controlling your laser power properly, with the caveat that you need to turn off the laser enable switch, or turn off the K40, before powering off the board. If my understanding is correct, then that gets you up and running for the immediate future until we figure out a long term solution.

Hissing is unrelated, see here:

Hopefully you are able to start getting some things made with your laser, and I’ll be back after the holiday weekend. Cheers!

The part that still has me confused is why the laser fires if I power on the K40, but not the board. Then if I power on the K40 and have the board powered the laser doesn’t fire.

Obviously, also confused why the normal 4 pin doesn’t work properly.

Sounds like you are thinking this is more of a temporary solution until we can resolve the underlying issue? Possibly replacing the opto?

Thank you for your help thus far! I hope you have a great holiday weekend away from work and stress! Looking forward to connecting after the holiday to keep plugging away at this.

@Cohesion3D following up on this. I am glad we got the laser to temporarily work under certain conditions, but I still want to resolve the issue of it firing on its own if the board is not powered on, but the K40 is. Something seems wrong to me… The laser should NEVER fire on its own, right?

Appreciate all the help you have given so far, hoping to resolve the issue completely.

Dylan, can you put a volt meter across the L signal and Ground on the LPS and tell us what the voltage reads with the C3D unpowered and then with it powered?

It is just strange the K40 will not fire with the L signal disconnected from C3D but will fire connected even when C3D has no power.

All measurements below reflect being wired as Ray suggested above. The “secondary” way of wiring G and L

K40 Off
C3D Not Powered On
Voltage across L and G at LPS: 0V

K40 Off
C3D Powered On
Voltage across L and G at LPS: 0.15V

K40 On
C3D Not Powered On
Voltage across L and G at LPS: 1.85V
Laser fires on its own upon powering on the K40

K40 On
C3D Powered On
Voltage across L and G at LPS: 5.13V
Laser does NOT fire upon powering on the K40

SOMETHING is very strange… the C3D should not be pulling down the 5.13V pullup on the L line inside the LPS when the C3D has no power…

The stepper motors are pretty well isolated from any other power and their only power is the 24V power supply of the C3D so the motors can’t be causing any ground loop or bleeding any power into the C3D.

But what about the end stops, are they mechanical switches or are they inductive sensors? In either case, do ALL wires from the end stop switches/sensors lead back to the C3D and nowhere else?

It would be nice to know what on earth is causing a disabled/depowered FET to pull down this LPS L signal from 5.13V. Have you checked to make sure no mounting screws are shorting out anything on the board to the chassis? Have you measured the voltage between the chassis and the GRN pin on the LPS(it should be 0VDC and 0VAC)?

Also, when you say the C3D is not powered on so you mean the USB cable has been disconnected AND the 24VDC barrel jack has been removed?

Endstops are mechanical switches, and wires trace from the endstop switches into the plug on the C3D board. X and Y wires all trace back to the proper plugs as well. All seems in order there.

I just checked continuity on my grounds and the results are as follows:

Chassis to LPS: 0 ohms
Chassis to C3D: 0 ohms
LPS to C3D: 0 ohms

Measuring voltage between chassis and LPS G is 0V when I power the K40 on. Same result with the board not powered as well as powered.

Mounting screws appear fine. They line up great and aren’t touching anything on the board. I used the plastic spacers too, so it all looks good.

Yes, when C3D is not powered on, the barrel jack and the USB are both disconnected.

@Cohesion3D any ideas??

1 Like

Last idea is just a hack to try and pull the L signal up to 5V when the C3D is depowered and that would be to try a 4.7K ohm resistor on the LPS connector from 5V to L signal. Then see if depowered C3D lets the L signal pull up to 5V and keep the laser off.

@Cohesion3D Ray?? Really need your help here to resolve this issue. The board is not functioning as it should. I know you are busy, but this was an expensive board and I need your help to fix it.