K40 Laser begins firing as soon as machine is turned on

Machine: K40 with Digital Display and M2 Nano Board

Board: C3D LaserBoard

Firmware: I have a new board and I’m using what it came with.

Problem: Brand new K40 with digital display and M2 Nano board. I did a quick test of the stock setup and the machine powers up, auto homes to the top left, and I am able to test fire the laser.

I then installed the C3D board as described on the website by doing the following:

  • Hooked up X and Y connections
  • Plugged in 4 pin, which has G, L, 5V, and 24V
  • Plugged in endstop connector
  • Connected DC into board
  • Connected USB into board
  • Plugged in SD card the board came with
  • Plugged AC power supply for board into outlet.

Had K40, water pump, and C3D power supply plugged into a 3-way extension cord.

LED’s lit up as described on the website for normal operation.

Hooked the USB to my Mac with Lightburn. I was able to jog the X and Y and send the laser to home. Prepared a test job by drawing simple squares. 1 in each corner and 1 in the center. When I tried to run the job I got the message saying there was an issue with the USB (I’m sorry I don’t remember the exact wording). I tried to unplug the USB and reconnect it and tried to run the job a few more times with the same result.

GFI outlet tripped. I reset the outlet and have moved the water pump and K40 power to an outlet and the LaserBoard to a different outlet.

Now when I power on the laser it start firing immediately. Only way to stop this is to power off the machine or turn the power down to 0. I was able to jog the X and Y in Lightburn and send it back to home.

What’s interesting also is once I hook my computer up and have the board powered on I can hear a hissing from the laser tube. It continues even after I turn the machine off. It only stops if I unplug the DC cord from the board.

LEDs still light up as normal operation. No visible damage to board on front or back.

What am I missing here?

Please help me! I am at a loss and am confused what is happening.

I hooked up the M2 Nano board and it powers up normally. Homes to top left and I am able to test fire laser, but it does NOT begin firing on its own.

Red and black going into the 4 pin on the c3d board are for the red dot that came installed on the laser.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.