K40 homes and jogs correctly, but not camera alignment test burn

Machine: K40 M2Nano

Board: LaserBoard

Firmware: “I have a new board and I’m using whatever it came with”

Problem/ Question: Issue is that when doing the test burn pattern of the “Calibrate Camera Alignment” despite being at HOME the laser will crash on the Y axis. I set the origin to the Front Left as described on this site, I also tried a test burn of another previously used file and it worked as expected.

Here is an image of the pattern and second test.

It burned the #3 and #4 bow tie targets first, crashed on the Y axis and then proceeded to burn everything else seemingly normal, albeit with the targets misaligned.

Hi IK,

Welcome to the forum! I have upgraded your trust level so that you can now upload pictures.

Check to see if you are working in ‘Absolute Coords’ mode in LightBurn, as the camera system requires this setting.

image

Do you have limit switches or endstops? Make sure your acceleration is not set too high, or the motor currents are not too low. Try running a few simple jobs with a small shape at each corner of the work area (like a circle or square) and make sure it doesn’t skip, then go back to the camera alignment job.

If you are using Nema 17 stepper motors, you can increase your alpha and beta currents in the config file. 1.0 is generally a good starting place, just make sure the motors are not getting hot. More information: Changing Stepper Motor Currents

Try lowering the acceleration settings (ex: 1500) and default_seek_rate (ex: 12000), testing with incremental increases or decreases until fine tuned. Make sure to power down before removing or reinserting the SD card.

Let us know if you continue to experience issues.

Hi there,

Thanks for the update, I’ve added the photo.

Check to see if you are working in ‘Absolute Coords’ mode in LightBurn,
I am, though they do oddly positioned. In my photo I added the position of a few corods.

Do you have limit switches or endstops?
Stock optical endstops, the “ribbon” K40 type. They appear to work as they trigger when Homing.

Make sure your acceleration is not set too high, or the motor currents are not too low.
Yes I bumped it to 1.2a, and dropped the speed to 100mm/s, at 500mm/s accel.

Try running a few simple jobs with a small shape at each corner of the work area (like a circle or square) and make sure it doesn’t skip
I have uploaded a second image showing this result. I used two seperate layers, on with the square sand the second with DB. The Y crashed again but then did the DB without positioning issues.

I have also added my current config file.

config.txt (28.4 KB)

Thank you for the configuration file.

The origin of your machine at 0,0 is based on the Cartesian coordinate system (like X, Y coordinates on a graph), so those approximate positions are expected. However, is your gantry coming all the way forward and to the left so that the head is in the corner?

Great! That’s good news.

1.2 is the max for the current values. Lower this value if the motors start getting hot.

Below are a few other parameters you can lower the settings for and test to dial them in. Acceleration values also live on the alpha and beta settings:

default_feed_rate                            1500             # Default rate ( mm/minute ) for G1/G2/G3 moves
default_seek_rate                            12000            # Default rate ( mm/minute ) for G0 moves

acceleration                                 1500             # Acceleration in mm/second/second.

alpha_acceleration                           1500             # mm/sec²
beta_acceleration                            1500             # mm/sec²

Once you get those settings dialed in, try running the four square test and if it looks good, try the camera calibration again. If it’s still skipping, please let us know what you updated and to what values, as well as the results of the new tests.

Hi there,

However, is your gantry coming all the way forward and to the left so that the head is in the corner?

Yes if I tell it to go to 0,0 it’ll move all the way to the Left Forward position.

1.2 is the max for the current values. Lower this value if the motors start getting hot.

There is a mechanical issue, one of the drive shafts is askew and got a new one on order but till then I need the motor to power through it. Only an issue when driving around 100mm/s on the Y.

If it’s still skipping, please let us know what you updated and to what values, as well as the results of the new tests.

The square test comes out OK, and I lowered the settings as suggested.


So separately it works normally now… I did the square test and it came out OK, but then the alignment test did the same Y crashing. I was in the process of recording a video and did the alignment test with my laptop’s integrated camera while recording on the laser camera and it worked, I then went back and redid it using the laser camera again and it also worked.