K40 Halting Mid-Cut w/ C3D LaserBoard and Lightburn

Machine: KeHui K40
Board: LaserBoard
Firmware: Smoothieware

Problem/ Question:
Hi Everyone, I’m running into issues cutting or engraving with my K40 using a Cohesion3D LaserBoard and Lightburn software. I can home the laser, jog/move, fire/test etc, but when I actually start a job, the laser will fire for approx. 5 seconds and then either stop moving and firing completely, or continue the job without actually firing. I’ve also had issue with the head skipping and jumping on cuts, including at lower speeds (50mm/sec).

To make try and test that it wasn’t the laser itself that was off, I uninstalled the C3D LaserBoard and reinstalled the stock M2 nano and ran a job with k40 whisperer. Laser cut fine. No skipping, no halting. I reinstalled the C3D board and tried cutting with Lightburn and still ran into the stopping mid-job. I’m not sure if it’s Lightburn, or the LaserBoard. Can you all help me narrow this down? If it’s a helpful detail, my in-cabinet light also stopped working when I initially replaced the M2Nano with the C3D.

Pics included of my setup + board install and other wiring, as well as my test cut + test design.

Thank you!

Setup + wiring

Test design + test cut
Screen Shot 2020-08-12 at 1.47.59 PM

Hello Tess,

Thank you for providing the pictures of your setup and wiring.

There is a thick, light red/orange wire coiled near the top of your board, which appears to be the high voltage wire that goes between your LPSU and tube. For reference, high voltage wires should be as far away from the board as possible to cut down on any chance of interference or other surprises.

Is the LaserBoard power supply plugged into the same power strip or outlet that your laser cutter is plugged into? Is there any other electrical appliance on the same circuit which could cause electrical interference when kicking on and off? We recommend that the board be isolated on its own circuit to test if this may be the case.

As for the jumping and jerking, try updating your configuration file, testing with incremental increases or decreases until fine tuned.

  1. Power off the C3D Board and remove the memory card. No lights should be on.
  2. Put the board’s memory card into your computer, using a MicroSD / SD reader if necessary.
  3. Open the config.txt on the memory card using an editor such as Sublime Text. Do not use Notepad++.
  4. Decrease the acceleration settings to help slow down the cornering speed and default_seek_rate will help slow the moves between cuts (Ex: 1500)
  5. Decrease max speeds, testing lower values incrementally until fine tuned (Ex: 18000, 12000, 9000, 6000)
    x_axis_max_speed # mm/min
    y_axis_max_speed # mm/min

We will start here and work forward depending on the outcome.

Hey Starla, thank you so much for the thorough explanation and breakdown of what could be going on with my K40. I’ve been unable to take a look at my laser setup due the local fire complexes here in California, but I will take look tonight or tomorrow and reply more in depth. Thank you once more for your knowledge!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.