K40 / Cohesion3D board / lightburn connection time out

Machine: K40 came with M2 controller

Board: Cohesion3D

Firmware: Smoothie

Problem/ Question: Hello everyone,

I bought a K40 Julong laser with an M2 controller, bought the Cohesion3D board, changed it inside the laser and I’m trying to work with it via Lightburn.

My laser is properly grounded (checked with a voltmeter), on a separate electrical circuit from any other device, including the power for the C3D board or the computer, the usb cable is screened and filtered, connected via a usb hub with additional power in it, short lenght cable, so no problems there.

The board installation and setting up in Lightburn was done accordingly to the specs found on this site documentation pages.
Lightburn is connected to the laser, it can control it, homing and moving around are good, problem starts when I try to engrave or cut, so either “Fill” or “Line” settings in Lightburn. The job stops at random times, with either the Lightburn message prompt that the usb connection is lost, sending me to the troubleshooting page of Lightburn (https://docs.lightburnsoftware.com/Troubleshooting-Connection.html#losing-connection) or no message at all, just the console displaying the “port already in use” error.
Tried a com port listening software that showed no other device or program in my computer messing around with that port but the Lightburn, the com port is set to 115200 baud rate, the board is responding to that baud rate, Lightburn is set to ignore all other ports used by the computer as instructed by the troubleshooting page of Lightburn (link above), I even tried with a remote access and removed every single usb cable (including mouse and keyboard) from the computer leaving nothing but the A-B usb cable that goes to the laser, in Device Manager I unchecked the box for FIFO buffers in com/properties/advanced, the computer mainboard has usb 2.0, 3.0 and 3.1, tried every option there no dice.

Help! Please!

Did you provide those pictures? We need pictures to understand your setup!

I am having the same sort of trouble but mine is not a timeout, it just freezes. If you are using a laptop or power saving modes then the computer can be set to switch off a USB after an amount of time and this is easier to do in windows 10 than in 11, in the advanced USB settings. good luck, if it’s not that then we’re in the same boat, unfortunately.

No laptop and I messed with those settings too, no USB timeouts.
And sometimes I get that kind of error too, lightburn just keeps sending data, the counter goes into -, the laser stops because it doesn’t get any data, no error messages no nothing, so I have to stop the process in lightburn, select another com, reselect com6 and then it’s like nothing happened, the laser is homing, lightburn is connected with it again.
Forgot to mention, I also did a reset on the C3D board.

C’mon, guys, I can’t believe there are only two people that have this problem.

Sorry to get your hopes up that I was going to be the one that had the answer. My biggest concern for you and all of us is what appears to be Ray and whomever he had doing support has abandoned the forum and the webpage.
I posted the simplest of challenges concerning any changes needed on the SD card for a rotary to be attached. Not a single reply.
As for you issue, be sure you have a high quality USB cable with chokes on at least one end, maybe both. Depending on the routing of the cable it could picking up via inductance enough interference to cause an error. There are a lot of non-choked and non-shielded USB cables. The first one I used give the an issue similar to yours. It would stop and Lightburn would indicated that the USB was not connected. Replaced the cable with a choked one and never had the issue again. Forgive me if you have already tried this, I skimmed your posts and may have missed some details.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.