Issues with GRBL LPC

grbl-lpc

(Caleb Chico) #1

Machine: DIY 80w using LightBurn, running on Windows 10

Board: LaserBoard

Firmware: GRBL-LPC 1.1

Problem/ Question: So I’d say I’m pretty quick to pick things up but I’m just having the worst time with GRBL and smoothie is too slow for my liking.

I’m using one of the firmwares that was compiled by @Jfong but since my machine is custom built I’m having to go in and configure a few things. Where my end stops are, dimensions, etc etc. I can do this all just fine and the laser works. However every once in a while something hiccups, and I get an error 7 and all the settings return back to default making my machine crash in every which way.

Sometimes I can send $ values no problem and I get an ok back, but other times I try to change a value and things just hangs, reset the machine, comes back on, error 7 and resets the values again. I’ve been messing with it for about 4 days. I have some of the settings saved as a macro but if the macro I send has more than 1 command at a time then the system hangs up and everything repeats.

Is there a way to make the values that I change become the default values? Every time I get the error 7 my machine is rendered useless because it goes back to thinking that it’s a k40, changing my steps configuration, sensor position, etc.

I read his blog and there is a lot of useful information but the link that he provides that is supposed to have information into compiling ones own version is not working so I’m just not sure what to do at this point.

Any advice would be appreciated. Thanks.


#2

Have you tried to reflash GRBL-LPC onto the board at all to see if that helps the issue?

The options are pretty much either to compile your own grbl-lpc with the values you need, or - I’ve suggested the Macro with $ lines to people before and it seems to have worked. In fact, this is how LightBurn handles the Machine Settings. Have you used that method at all?


(Caleb Chico) #3

So I’m still puzzled by all of this. I tried using different usb cables, bought and placed rfi filters wherever applicable, reflashed the firmware, reformatted the sd card and tried flashing the firmware again but still the same issue. Also tried running it from a different computer and tried using a different driver and still the same issue.

Sometimes it lets me change the settings and it will keep them and work for a bit, but just now I sent $100=89.064 to update the steps for X and now im getting a busy error that won’t clear up until I reset the machine. Now I’m a bit more puzzled than before.

Whenever the settings stick and I’m able to send a job, I’ve noticed that it cuts just fine, but if i set the job to scan the image warps. This was happening to me with smoothie so I switched to grbl and although images don’t slant as severely, it looks like someone with Parkinson’s is engraving the images.

Like I said it cuts fine but every scan turns out different. Doesn’t matter if I do dither, threshold, over scan or not, no matter where in the bed. The “Things” image was done in absolute coordinated and I was moving the piece of wood around.

Lens is tight, mirrors are tight, no rattleing anywhere.


(Caleb Chico) #4

Belts are tensioned. no physical teeth are skipping, everything is aligned properly, I’m hitting a bullseye on all 4 corners of the bed. This picture was done with smoothie. Same thing, it cuts fine but scan is inconsistent. Doesn’t matter if i do bidirectional or not.


(Caleb Chico) #5

Alright one last post for the meantime. This morning I got me an expensive cup of coffee from starbucks, came to my garage and just tried to brainstorm as to what is happening. I still have no clue what it is, but I decided to clean up all my cables and make everything a lot neater and tighter. I figured that it could not hurt at all but it could definitely help if it were noise related.

It’s also time for me to take a step back and do some basic trouble shooting. I have 4 drivers but for testing purposes I only need X and Y so I’ll leave the other two disconnected, don’t need sensors, etc etc. I’ll try to minimize the load on the power supply (although I definitely got plenty of juice) and I’ll run an even shorter usb cable. I’ll start there and work my way out. I’ll report in a day or two.


(Caleb Chico) #6

Alright, so I cleaned up all the cables, routed a few cables a different way just in case, cut all the excess and made the cables as short as possible. Then I started testing with just X and Y, left Z and A disconnected. Each axis is plugged to an external driver.

This is what I’ve discovered so far.

After only testing X and Y I still kept getting the sliding issue. The laser would cut lines perfectly, no matter how intricate the design, but if I set it to scan, it would perform differently every time. There was no distinct pattern, just a mess all over the place, pictures posted above. I checked everything physical I could think of and tried to both loosening and tensioning the belt. So then I moved a different direction.

I then tested the driver, maybe the one for X was bad, so I swapped it with the other two I had for Z and A and I got the same results. I tried changing the settings using the dip switches then I would fix my steps on GRBL I would scan and I would get the same inconsistent crappy results.

I then tested the step motor, maybe for some reason it was bad, so I swapped it with 2 extra ones that I have, and the same results.

I then thought about just removing the driver for X and just plugging directly onto the Laserboard and that worked for the most part.

I’m still confused as what is actually happening though.

I’m atm messing with the settings to see if I can make it scan the way it should. Although the difference is night and day, and now can scan things that don’t look like Michael J. Fox hand drew them, the system is still hiccuping every once in a while. Sometimes every few passes it will slow down for one pass and then it goes back to scanning normally, and then it happens again.

And sometimes I’ll scan an image, move the piece of wood, start the scan again and the quality of the print is slightly different.

So now I’m not sure if the issue is GRBL anymore since I was still getting the sliding results with smoothie, or if its the board in some magical way since I can only use X plugged directly and won’t work properly using an external driver like the other axis, or if it’s just me… it’s probably the last one.


(Fredrik Johnson) #7

I got a problem like that you describe , i got two external stepper drivers,
When i cut it works fine , but when i Scan it is missalignment.
I think its Only on x axis its wrong .

Did you come up With a sulotion ?


(Caleb Chico) #8

Hey Fredrik,
The only way that I managed to get past it was to connect my X axis directly to the cohesion 3d laserboard and not using the driver for that axis. I tried every setting that I could imagine on grbl but nothing worked. When I was doing trouble shooting tried changing step drivers and nothing, even changed motors and the problem persisted with X, at the end I just plugged the cables directly to the board and it started working as it should. I’d say give it a try. If it works or you figure out another solution let me know. Hope this helps a bit.


(Fredrik Johnson) #9

Thankyou for answered,
Did you just connect the motor cables to X , and use the
External stepper drivers to Y ?

I tryed too connect just X to the Laserboard , but then it did not moved
In either X or Y .


(Caleb Chico) #10

Here’s a pic of my board. I just got the 4 cables that came out of the motor and connected them directly to the board for X., and the rest of my axis are connected via external drivers. Your Y axis should still be working even if your X is disconnected. Are you using Smoothie or GRBL? You might have to change a few settings around.


(Fredrik Johnson) #11

Thankyou Chico , for taking your thime,
I connect as you recomended , connect X Direct too the board ,

And it was the best test i did so far , I Will do some moore test ,
And even try too find a sulotion so i can use the external stepper driver .
I Will let you know if i come up too something.

If nothing else work ,i hope this Will work

Thanks again chico , for all your help.


(Frank Saltheim) #12

Hello, Chico!
Did you get that over with keeping the parameters under control? I have the same problem. Everything I change in the machine setting is not preserved. Whether I reset the driver or not, the parameters are always gone. I’m desperate, …