How do I set up my stepper driver and Motor on Z axis correctly?

Machine:K40
Board: Laserboard V.1.0
Firmware:
Build version: edge-54d22942,
Build date: Jun 5 2019 14:09:26,
MCU: LPC1769,
System Clock: 120MHz
CNC Build
NOMSD Build
“I have a new board and I’m using whatever it came with”

Stepper Motor: Model:42A08 - Nema17 (60mmLänge)
http://www.rtelligent.net/42mm_Series_2_Phase.html
Sticker Motor: 1.5A / supplied data sheet: 1,8A / Specifications on Website: 2.0A
:rofl:

Stepper Driver:

How do I correctly configure my stepper motor with the stepper driver?

According to the sticker, the motor has 1.5A. On the supplied data sheet it is stated that the motor has 1.8A. The manufacturer’s website states that this model has 2.0A.
:rofl:

What do I choose from Microstep / Pulse rev?

Do I have to rewrite data in the config file?

How can I calibrate the actually driven height from the table to the information in Lightburn, so that I say, go down 10mm, the table actually only moves 10mm.

How can I specify Z-0 and Z max. Which the table is allowed to move at most.

Mechanical end stops have been ordered.
Do I have to set the end stops in the config file or just connect them to the board.

Hope you can help me.

This should get you started:

As far as the microstep setting goes start with 16x (3200/rev) and see if you can drive your table accurately with it. When in doubt with the currents, start with the lowest value and see if you can jog the table around without losing steps. If the motor doesn’t get too hot during use it should be fine at that setting.

  • Why are the X, Y, Z axes not stopped by the end stops during manual movement. This only works if it is driven “automatically”, then the axes stop at the end stop.
  • How can I reduce the speed of the Z table when i drive them with a move “G0 Z” command in console?

When I move the table using the up and down keys in Lightburn, the movement is very slow and everything is fine. But when I move the table over a greater distance in Lightburn with a “G0 Z” command in console, it goes down very quickly, but at the fast speed it gets stuck when moving up.
Or is that a problem with the setting of the stepper driver?

These end stops were used.
https://www.ebay.de/itm/mechanischer-Endstop-Endschalter-3D-Drucker-Kabel-Reprap-Schalter-Endstopper-/284291128081?mkcid=16&mkevt=1&_trksid=p2349624.m46890.l49286&mkrid=707-127634-2357 -0


Follow the steps in the article here https://cohesion3d.com/knowledgebase/testing-endstops-homing-sensors-on-laserboard/

That should get you started. as far as the seek rate for the table goes, you’ll have to play around with the steps per mm, acceleration, and max rate settings for the gamma axis until they’re correct. I’m underwater at work so I can’t take any time to elaborate more, but if you do a search on the forum you should be able to find a few posts where we’ve talked about how to determine optimal values.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.