Homing moving in wrong direction and other issues

Machine & old board: K40 with the M2nano

Current Board: C3d Laserboard

Firmware: Smoothie Cluster (just downloaded from forum)

I’m not sure about my end stops… They always seem to report 1 when I run the M119 command… They are the little pink boxes with nothing exposed on any end, I am guessing they are magnetic… They are spliced with the power lines so I am assuming they are powered…

Does anyone know anything about these end stops and if there’s any special config I need to use with them?

Also the laser seems to work properly, but when I hit Home in Lightburn the X moves away from the origin and end stop (to the right) and the Y moves towards the origin (away from the end stop) It only moves a slight bit, I am guessing this is because it thinks the endstops are pressed since they show up as 1, but the point is it’s moving int he wrong direction.

This all worked fine with the original board so I am not sure what’s up and what I need to do to fix it…

I’ll keep playing around but any advice is appreciated.

I’ve heard this described a few times in the last month. “China did something weird recently” is the best explanation I have so far.

I’m trying to figure it out, but one guy hasn’t gotten back to me yet, the other one identified the style sensors that you described but hasn’t received his board, and there’s a severe language barrier with the last one.

So, please show pictures of these sensors, your machine, and the wiring going to the board installation, trace the wiring from the sensors, and get me all the information you can.

Yes, this is appropriate behavior. It thinks the stop is pressed so it is moving away first to clear it, but the stop is not getting released. Let’s figure it out.

I’ve had the laser for about 6 months now so it’s not a super recent unit.

I just got my laserboard installed yesterday.

I tried the pull up, down and none options in the config file to no avail. Putting the ! in there made them return 0’s and all hell broke loose as expected. I wasn’t able to do anything that got it to toggle though when moving the bed in/out of the end stop areas.

I’m fairly technical (though mostly a software guy) and you shouldn’t have any language issues with me as I’m a native English speaker.

I will run down a take some pictures shortly and hopefully we can figure this out!!

I can tell you the end stop connector went into the expected place just fine on the C3D board, and the end stops are spliced into the 4 pin large power plug. I don’t know if the probes on my meter are small enough or my hand is stable enough to meter it for ya but I will see what I can do.

I was able to still use the laser by manually keeping the head within the bed and setting it at the home position at power up manually. On that note it would be nice to be able to unlock the servos for manual movement of the head without having to power the whole thing down.

Anyway I will get you some pictures shortly and let me know if there’s anything else I can do to help solve this.

Thanks

Interesting. Well all the instances of this started popping up in the last few weeks! It’s not what we are expecting, as the last number of years I have been doing this all the M2Nano based machines have been either mechanical limit switches or optical sensors.

Yay!

The gCode command for this should be M18 and I have Macro 6 in LightBurn’s console tab named as “Disable Motors” with that gCode contents.

Looking forward to pics.

I got pics of the machines date sticker, the end stops, their specs on the back of them, the old board, the new board and the wires…

The endstops have specs printed on them:

Looks like FOTEK PL-05N2
Brown: +V
Blue: 0V
Black: Out
NPN 10-30VDC

Hopefully that means something to you… I’ve attached a bunch of pictures, let me know if you need anything else.

Thanks for the help!!!

Will have to make a few posts to get all the pics up it seems… Stand by!

Also thanks for the Gcode, I will setup that macro next time I’m working on it.

Quick Google pulled up this datasheet: http://www.fotek.com.tw/pdf/etc_227.pdf

Not sure if any of that means anything to you :slight_smile:

Where is the Brown wire(s) going to, exactly which pin? Pull off the hot glue please.

I think I figured this out while sleeping on Sunday night. I need that answer ^ and I will need you to take some voltage measurements with a multimeter to confirm what I’m thinking.

That is the old picture… I’m not using that board anymore and the glue is gone (we other pics)

Based on what’s written in the back of the sensor the brown wires in the grey sheath are going to +50 but its for sure spliced into the power connector.

The blue 0v / gnd wires are going to the outside pins of the end stop connector with the 2 black signal wires in the middle and the first 5v wire not connected. Based on the pinout this seems right…

Is it possible that the two differnrt power sources are the issue?

The gnd is coming from the laser boards power supply but the sensor power is coming from the laser PSU and it can’t make a proper circuit? (again I’m somewhat enept when it comes to electronic circuits)

I’ll be home in 3 or 4 hours and I can trace some wires for you and try and take a measurement if need be but I am pretty confident of the wiring I described above.

Thanks again for the help

Not sure if I can edit the above but I meant the brown wire is connected to +5v on the laser power supply that came with the machine not +50

There are 2 things that might be in play here:

  1. Lack of common ground for that to work because the board is isolated form the 5v and 24v rails on that plug, so the ground is not shared as a stability and protection measure.
  2. The fact that these sensors are meant to be run at 12/ 24v and they are being run at 5v because that’s all the M2Nano can take.

Please confirm that the brown wires are going into the 5v position on the power plug when you are home. Meanwhile, I will give thought to the best way to work around this.

The sensors say on the back of them “Brown: +5V” so I’m almost 100% sure the sensor is getting +5v from the power connector and you are likely correct that the lack of a common ground is causing either the signal to be wonky or the sensor to not get power at all.

The sensors worked 100% fine with the M2 Nano, the problem only started with I installed the Cohesion board.

If the pin-out I saw was correct the left most pin on the C3D board is +5v so if I remove the brown wire from the splice into the power supply and put it into the empty pin on that connector it should solve the ground issue, correct?

I will confirm when I get home which pin it is spliced into on the power wire coming fro the LPSU

You don’t need to get into that tiny one in the “M2Nano equivalent endstop connector”.

The entire bottom row of the endstop connectors, the V+ should be 5v. So if you have some dupont jumper wires around and are comfortable cutting the brown wires from their original positions to connect them to the 5v on the LaserBoard, that should get you what you need.

That’s good to know/ interesting… On the document you linked I thought I saw the brown wire with a voltage callout of 10-30v which is a fairly typical thing to expect, but that may have been a mismatch between models.

Look at this pic… it lists both voltages… I don’t really know how that’s supposed to work stupid Taiwanese :stuck_out_tongue:

It does say though that it’s expected +5v on Brown and 0V (GND) on blue and black is the output wire… and the 2 blacks are going into the X/Y end stop positions on the Laserboard.

I also just confirmed that the two brown wires ARE going to the +5v from laser on the power connector.

I do have a dupont wire… I will go try this now and report back within the hour.

You are right, I am seeing things :stuck_out_tongue:
It just says +V on brown and 10-30v at the bottom…

The brown wires are for sure going into position 2 or 3 of that power connector (depending what side you go from) though, the one right next to laser fire which according to the diagram is +5V. I can try and meter that before I start cutting wires…

Yes, this is why “I don’t believe you, show me” is my most common support phrase used, although I do tend to spruce it up somewhat before hitting send. It’s mostly why I ask for pics all the time. Seriously though, that’s the only way I can catch things. And there’s always stuff to catch that I would never think to ask about. Much more pleasant to peruse pics than have to play 100 questions.

So anyways (tech support rant over :slight_smile:)…


Yeah, it’s 5v. Set meter to voltage measurement max 200 just in case you get 24v somewhere we want to catch it.

You can pull the endstop plug out of the C3D for this, and the power plug too. I explicitly suggest this in case your probe slips, I don’t want you to harm anything important :slight_smile:

Sensor not triggered.
Positive lead on the output wire in the endstop plug.
Negative meter lead on Laser’s Gnd - either in the power plug or on the LPSU where it goes to a terminal block.
You should see 0 voltage?
Trigger the sensor. You should see a voltage. Or maybe it’s the flip but we’re looking for a state change.

Now do the same test again but have the negative lead on the ground of the C3D board. We’ll actually need both connectors back on the board for this one.
To access the endstop signal you can tap into endstop row, X min for X and Y Max for Y, the sig pin. Get a dupont on it and meter that with the positive lead,
For ground we’ve got a nice screw terminal in the top left you’ll put the negative probe on.

Hopefully this manic direct thoughts out of my brain makes sense. Thanks for doing this testing.


Inductive sensors are not meant to be run at 5v. It can work but can be finicky. We’ll tackle that later if needed. It’s not like we’re trying to prove a 3D Printer bed to hundredths of a mm here.

Used to work in tech support, I’m totally with you.

Metered 5V on that brown line. Just jammed the probes into the top of the connector so there was nothing to slip.

My 24v from laser fell out of the plug while screwing around… Hopefully that’s not important for laser fire…I just taped it off for now…

I cut the brown wires and wired to the +5v from the C3D… Now the pink sensors are both lighting up… I forgot they did that… The LED goes out when the switch is “pressed”

My X axis is now homing properly and I get a 1 when they light is out and axis is homed and a 0 the rest of the time.

My Y axis however is always reporting a 1 even when the light on the sensor is out… Any ideas on that one?