Homing, driving, motor issues for larger laser

Machine: ChinaCNCZone 1060. M2Nano (pictured below)

Board: Cohesion3D LaserBoard (pictured below)

Firmware: I have a new board and I’m using whatever it came with (did also download the firmware from your site as the file was a cursor type file not a bin file? but was same issue)

Problem/ Question: G’day, my device is a larger than K40 style (1000 x 600). The device has Normally Open limit switches (pictured below) that are located at Home B (top right). However, the motors are attempting to drive themselves into the neighbour’s house. I have run the M119 test to ensure that the limit stops are operational (they are, although in the code they are #out and false?) my X limit switch has now failed due to the tests I ran when I was problem solving the board (according to the M119 code, however, when I reinstalled the Nano board the limit switches work?). I have a spear but think that given it works on Nano and C3D this it might be a wire issue not a switch issue?

Problem solving thus far:

  • I have read your guides and sub-guides about larger than normal beds and adjusted the size as advised.
  • I have slowed the drive speed and default speeds down (they still are jumpy till a point then it just drives as quick as it can in a direction).
  • I have inverted the direction for the Y as its driving down not up.
  • I have attempted to use the downloaded firmware (different file type to what was on the SD card)
  • I have attempted to reinstall the device on Lightburn but it can’t find it now and reverts to the old install.

My thought (from what I read in your Docs and Guides): That most of this will all be sorted once the laser knows where it is and what its working with (ie we can figure the Original position and Home position stuff out).

P.S. I tried to add photos as requested, however I don’t have the rights to add (‘Sorry, new users cant upload photos’ error)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.