Homing alarm not clearing

Machine: Preenex K40 laser

Board: cohesion3D laserboard

Firmware: _Smoothie …I have a new board the Cohesion laserboard

Problem/ Question: I installed my board and everything was running smoothly, used it for about a week no problem, then nothing. The only light was the vmot light. I un plugged everything reinstalled my nano board everything works fine, with Inkscape an k40 whisper. I then removed the nano board again and reinstalled the cohesion board, all lights worked after I hit the reset button. But now all I get is a homing error. I bought another flash drive reinstalled the files. Still nothing, the x,y will not move even with control in light burn. I even deleted and reinstalled lightburn. M119 in control = x 0 y 0 when not touching homing switch x 1 y 1 when touching.

Adding additional information

[quote=“KenNunley, post:1, topic:1412”]
again
[/quote]

This means the board is reading the limit switches/ homing sensors properly - good, board is working properly.

Is the head reaching and able to press both switches?

Thank you for the pictures, if you can upload a video to Youtube of trying to run a homing sequence and getting this error, I would like to see what happens.

I had to unplug the machine and manually move the head and gantry to touch the limit switches before imputing the m119 command. I would take a video but nothing moves head or gantry, it is like it is locked up. When I power up the cohesion3d card there is a thump that sounds like something wants to move but nothing does and there is resistance if you try to manually move the head or gantry so I don’t move it by hand when powered up. But I cannot get past the alarm screen in lightburn, any type of move command or burn command results in the homing alarm. But when I install the nano board everything works fine it will home and laser cut perfectly. I did take a video of the board, L2 and L3 don’t blink at the same time they are alternating, I don’t know if that matters, on the diagram in the forum post they were blinking at the same time. I’ll try to get the video posted if you need it. I did however change the endstops_enable to false in the config file. I didn’t get the alarm but still nothing moves, it will even send a cut command from start to finish but nothing moves. Let me know if there’s anything that I can do to trouble shoot this.
Thanks
Ken

Console info with head and gantry against limit/homing switches. Moved by hand with power off.
The idle Mpos is from the get position under the Move console.

Just a side note after testing the end stop at false I reset them back to true in the config file.

Sorry for the delay in responding, I am currently trying to keep up with an increase in order and support volume.

With homing enabled, sending M999 will clear the alarm, if the board starts and you are in an alarm state can you send that command and see if everything works properly after?

I tried the M999 in control and then tried to home, still the same thing.
I also Tried resetting Lightburn, reflashing the New SD card, still the same. My machine still works with k40 whisper finding the limit/homing switches. We may need to discuss other options since I’ve been at this since 1 December. I think I’ve read most of the posts on the forum about 15 hours and 2,500 posts. Thank you for your support but I don’t know what else there’s to do.

Ray,
I have done everything you asked me to do. I’ve posted pictures made videos and even spent more time necessary reading about other people’s experiences. I’ve emailed you and haven’t received any response. I am hanging in limbo with my board without any support from you. It has been 27 days since My last post when I did what you asked me to do and posted it. I have yet to receive a response from you about what I can do next. I’ve offered to pay you to check my board with no response. I would like to get my machine back going again in the near future.

Thanks
Kenn

Hi Ken.

Yes, we need to get you taken care of.

Without going into my entire life story, the quick synopsis is that the last 2 months of the holiday season were completely crazy, there was a significant uptick in orders to build, pack, and ship, an increased support load to deal with, and the standard 5,000 other things piled on that comes with running a business.

I was overwhelmed, barely keeping up, and a handful of customers with the “less simple” inquiries that required more detailed attention, such as yours, completely fell through the cracks.

Please accept my sincerest apologies for this.


Anyways, I think the hold up was that I was going to write up the “what we need from M119” follow up. Please see below. Just check that for me quickly and if that doesn’t yield any useful results then we’ll get you a new board out.


M119 Instructions:

Use the M119 command on Smoothie firmware to test the endstops being read, as explained here:

Turn off homing on connect in LightBurn device setup so that you can do this without the board locking up, otherwise send M999 to clear the alarm.

Complete the M119 test fully - this involves sending the command while the head is “in the middle” - not touching any switches, when it is pressing the X switch, and when it is pressing the Y switch.
The result, and feedback that I am looking for, is 3 clearly identified response strings.

  • “Here is the result of M119 when no switches are being depressed”
  • “Here is the result of M119 when the X switch is being depressed”
  • “Here is the result of M119 when the Y switch is being depressed”