Help with controlling air assist via lightburn

Machine: k40 m.2

Board: Mini

Firmware: Smoothie
Problem/ Question:
Hello… I am trying to control the air assist using the mini board. I’ve read and realize that the config file has to be switched to “true” and have done so. I’ve tried connecting the relay to the pins on the board but to no avail… when running a cut on lightburn with air assist option turned on (green) nothing happens… so far I’ve only just tested the relay and not at all connected to my air compressor. Here are a couple of pics… the angle on the board isn’t great but you should be able to see it.

That is a 5v relay I’m trying to control with the board… I guess I’m confused… Do I have to supply the 5 volts to the MOSFET? is that what the 3rd pin is for? Or does the board put out 5 volts to switch that relay?

This is what I’m controlling… basically just a flip flop for these solenoids… not even turning on the compressor.

Please let me know whenever you have the time. Thanks
Did you provide those pictures? We need pictures to understand your setup!

Hi Paul,

There is 5v available from the board itself, such as the top 2 mosfets (FET3 & 4), one of which you are connected to, but that is a very small amount.

image

We recommend using the FET2 (P2.7) on the bottom of the board, as it is larger and will provide whatever voltage you feed from a separate power supply into the input terminal on the left side. You should install a flyback diode to protect from voltage spikes and ensure board stability with an inductive load, such as a solenoid valve or relay. Verify how much current this device will take and make sure the C3D board is powered from an external PSU.

image

It looks like you already found the fan control section in the config file and enabled it. Great!
LightBurn uses M106 and M107 commands to enable and disable when the Air Assist feature is used in the Cut Settings Editor on the layer. The default pin is set to 2.6 for the Mini, so it will need to be updated in the config file to the pin you connect to (i.e., 2.7). FET1 (P2.5) is used to control your laser, so do not use that one.

## Switch module for fan control
switch.fan.enable                                  true
switch.fan.input_on_command                        M106            #
switch.fan.input_off_command                       M107            #
switch.fan.output_pin                              2.7             #

Please refer to our Air Assist documentation for general setup information: https://cohesion3d.com/knowledgebase/ac-relay-for-air-assist-exhaust-setup/

Thanks so much. yes… I’m a bit embarrassed to say. The problem is solved. Actually… it was never a problem at all. I had followed all the instructions and connected everything ALMOST correctly…

I had the polarity switched :frowning: But now it’s working great. thanks for getting back to me. Feel free to close this thread.

Hi Paul,

I’m glad you got it resolved! This thread will automatically self destruct in… 3… 2…
I’m kidding. It will auto close in 14 days. :slight_smile:

2 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.