Graphic LCD changes/ overrides lightburn settings

Machine: Chinese k40 (More compact + digital style, originally with m2nano non ribbon)

Board: Cohesion3D laserboard (2020) with GLCD and LB Camera

Firmware: I have a new board from Sep 2020 and I’m using whatever it came with

Problem/ Question: I have just started to install my new C3D board and accs in stages. I first installed the C3D board and installed lightburn on my W10 laptop. I followed the setup process and all went well. I set origin as bottom left and the machine homes at top left. I ran a few raster engraves to prove the function. I sent the laser home, to origin and to trace the job outline and all functions worked well and as expected.
I then installed the GLCD and booted up. Once installed the origin button no longer works on lightburn. The home button successfully homes the laser and now when i try to trace or start a job the laser wants to go up from home grinding against the hard limit. I can only see this being the screen being in absolute coords mode and uses its current position as origin (bottom left).
I would have thought when operating from lightburn, even if the screen is installed it would use the lightburn settings but it uses the screens absolute mode and is unusable. I had very limited time to fault find the issue so i will probably be back on it tomorrow but i am just probing for any ideas from people who have the GLCD fitted but operate their laser using lightburn. Have you had issues? Does a setting in the LCD need changing?
I will be back with more info soon hopefully.
Thanks
Mitch B

Hi Mitch,

I’m glad to hear everything is working with the LaserBoard and LightBurn prior to the GLCD installation.

Please provide pictures of your machine, board, other electrical components, and wiring so we can work towards diagnosing the issue with the display. A video of the behavior would also help, if you can provide a link and post it here.

I would also like to see a screenshot of your full LightBurn screen with the Laser Panel (no cellphone pictures, please), and also include the Device Settings menu (tool icon on the top toolbar).

When running jobs via the GLCD, you do need be in absolute coordinates mode. Connecting the screen should have no impact on the origin settings. You may find this post of interest: Setting Job Origin from GLCD

Hi Starla, Sorry for the late reply. I had to go away with work at late notice and returned today. I have been playing with the laser some more today and have improved the situation. I have installed the GLCD and reloaded my device settings in lightburn and both laser and GLCD work with the correct direction from origin.
At origin my coords read 0, 0 and i can jog both axis ok. I have taken a video of the setup and the movement of the axis. This however shows another problem i am having. The origin of my machine is 40mm short of the useable bed size in the Y axis (Also shown in video). I have tried increasing the bed size in my device settings but it still falls 40mm short in Y when moving to origin. I can manually drive it to its max bed size in which the coords will read 0, -40. I have also looked through the SD card config and cannot find anything to adjust. How does the machine find its origin or its 0, 0? Do i need to disconnect the drive belts, manually place the gantry and reconnect?

Thanks

Photos of Lightburn panel:

Lightburn Panel

Video of setup

Hi Mitch,

No worries and I’m happy to hear that you were able to get the GLCD and origin to play nicely together. Thank you for providing the images and video!

The origin of your machine at 0,0 is based on the Cartesian coordinate system (like X, Y coordinates on a graph). This is a helpful visual for the origin being set in the lower left hand corner - increasing the bed size will not affect this origin point because that is elongating the area upwards and/or to the right, depending on which values you edited in the configuration. If you have a standard K40 model, I would reset it back to 300 x 200 before proceeding, to prevent crashing into the gantry.

Please provide a copy of your configuration file so I can take a look. To post the config file, paste in a reply it with 3 backticks ``` above and below the content or paste the config file to Pastebin, Dropbox, or Google Drive and provide the link here.

Hard Reset

  1. Turn the machine off.
  2. Label and take clear photos of all of the wiring before proceeding.
  3. Unplug all connectors from the LaserBoard.
  4. Disconnect the USB and power brick.
  5. Allow the LaserBoard to sit for a few hours or overnight.
  6. Reconnect everything.
  7. Try clicking the Home button in LightBurn. Does it home properly?
  8. Try going to origin again from LightBurn. Is it going all the way to the origin?

Report back with the results of your tests.

Hi Starla,

I have the machine all unplugged and will be leaving it overnight. My config is : https://pastebin.com/9ztXxeCw

Thanks

Mitch

Thanks for providing your config file, Mitch.

The alpha_max value is set to 200. Please update this to 300. Everything else looks great.

## Endstops
endstops_enable                              true             # the endstop module is enabled by default and can be disabled here
#corexy_homing                               false            # set to true if homing on a hbot or corexy
alpha_min_endstop                            1.24^            # add a ! to invert if endstop is NO connected to ground
alpha_max_endstop                            1.25^            # NOTE set to nc if this is not installed
alpha_homing_direction                       home_to_min      # or set to home_to_max and set alpha_max
alpha_min                                    0                # this gets loaded after homing when home_to_min is set
alpha_max                                    200              # this gets loaded after homing when home_to_max is set
beta_min_endstop                             1.26^            #
beta_max_endstop                             1.27^            #
beta_homing_direction                        home_to_max      #
beta_min                                     0                #
beta_max                                     200              #

I’ll update that now and load it in first thing tomorrow. I’ll let you know how it goes then.
Mitch

Hi Starla,

I got to play with the laser today and attempted what you asked. First of all changing alpha max to 300 had no affect. I thought this was odd as alpha would refer to x axis. I then changed beta max to 240, my max bed size in Y. This then corrected the origin problem. Changing alpha max from 200 to 300 seems to have no affect on anything, i’m assuming the only time this will be used is if i origin to the front right. With these new setting i am showing the correct bed size and position on LB.
Thanks for you help
Mitch

Ah, you’re right. We’re homing to min on alpha in this instance. Glad you got it sorted!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.