Graphic display dies not light up

Machine: K40 w/NANO
Board: mini
Firmware: _Smoothie

Problem/ Question: The graphic display originally worked but I’ve had it unhooked while I made a new panel to hold it. Now the display does not light up. Otherwise the mini works as normal.

Additional picture.

On back of glcd.

You’ve got the adapter backwards. Flip it.

Thanks. This appeared to work at first. It displayed the smoothie firmware screen and then the coordinate screen. When I pressed the knob it gave me the selection screen. When turning the knob to select an option the screen went blank and I could not do anything. I turned off the laser and tried again, same symptoms. After the third time powering it off and on, I dont get anything on the screen. It flashes and the lights on the board flash and make a noise.

https://www.dropbox.com/s/4w5vfr87stnzy62/20190902_135755.mp4?dl=0

Better video
https://www.dropbox.com/s/o0x4r8fimu4uvsv/20190902_143124.mp4?dl=0

This problem occurs when the GLCD is plugged in. I’m not sure why it worked some then started this. Would the problem be the GLCD, the adapter or the mini bd?

Do you have any help for my problem? Thank you.

The LEDs all blinking like that is definitely not normal.

As best I can tell, your C3D Mini is being powered from the Laser PSU, which is woefully inadequate for the task and you are seeing a direct result of that here.

Please read:

FYI the dropbox video player does not work inside here so I redid your posts with hyperlinks so that people can click the link and see the videos.

Ok, this is new information to me. I knew that the laser board needed a power supply, but I didn’t think the mini board would need one. I will add a power supply and see if this fixes the issue.

https://cohesion3d.freshdesk.com/support/solutions/articles/5000783636-k40-additional-24v-power-supply-upgrade-guide

I have installed a separate power supply for the 5v and 24v, however this did not change my problem with the glcd. Do you have other suggestions? Thanks.

Can you show pictures of how you have everything wired up now?