Full spectrum 5th gen

Hey guys,
I am trying to replace the old board with the cohesion 3d laser board. My old board says 6th gen. I haven’t seen any of the boards from the articles here with the same wiring. Right now I am trying to get the axis X and Y to work correctly. It homes in X but does nothing when homing in Y. The axises do not move smoothly when trying to jog. I am using LightBurn Software to setup the board.

It’s good that you’re trying to get the motion control working first.

A few questions to start:
Where are your homing switches physically located?
What type of homing switches are they?
What model stepper motors do you have?

There could be a lot of things wrong contributing to the motors not behaving as they should.

James, I ran into similar problems when I installed the Cohesion 3D Laserboard on my FSL 5th Gen. A couple of items:

  1. I replaced the FET switches that came with the FSL with small dry contact switches. They are identified as “Mechanical Limit Switch” in the Cohesion 3D peripherals page. You will need 2. You may need to bore out one of the holes to allow the mounting screw to pass through it. These switches mount in the same place as the FETs. HOME will become the upper right-hand corner. When wiring, use the GRD and SIG pins on the X and Y MIN connectors, if you use the attached CONFIG file.

  2. I had to modify the CONFIG file which is loaded onto the SD memory card. Several lines were modified: X and Y homing direction; X and Y max speed; Alpha (x) and Y max speed and acceleration; A and Y max direction (bed size).

For what it’s worth, I have attached my config file which works with my FSL Hobby 5th Gen laser with a Cohesion 3D Laserboard.

Hope this helps.

config.txt (28.9 KB)

1 Like

This is fantastic - thanks for posting this, Pat!

Thanks for the reply. I believe my issue is with the feed rate. My optical end stops are working correctly. My laser homes to the rear right as that is where the stops are located.

Thanks for your reply. My end stops are in the right rear and they are optical. I have resistors like one of the other posts. Here is a picture of the stepper. it will home but I have to hit the home button several times I believe the issue is with the feed rate in the config file.

I tried your config file and the jog movement works fine now. It does not home to the right rear where my end stops are. It moves to the left front and keeps trying to go. When I turn the jog knob clockwise the axis moves negative on the control screen. Can I reverse the directions and everything work correctly?

There are a couple of ways to handle the issue.

  1. Rewire the X and Y stepper motor cable plugs to the Cohesion Laserboard. (Although I don’t recommend this option!)

  2. Edit the Config.txt file to reverse the travel directions for the Alpha(X) and Beta(Y) stepper motors. You can edit this file with a simple text editor such as the Notepad app in Windows. The two entries that should be changed are:
    alpha_dir_pin 0.5!
    beta_dir_pin 0.11

change to:
alpha_dir_pin 0.5
beta_dir_pin 0.11!

By adding/removing the exclamation point on these two lines you cause the direction of travel for these stepper motors to change the direction of movement.

Be sure to make a copy of the working Config file (e.g.: Copy Config.txt) before editing the Config file. The Laserboard will read only the file named Config.txt

Hope this helps.

The direction change worked. Since I have the optical sensors working the edits here need to be different correct?
alpha_min_endstop 1.24^! # add a ! to invert if endstop is NO connected to ground
alpha_max_endstop 1.25^! # NOTE set to nc if this is not installed

beta_min_endstop 1.26^! #
beta_max_endstop 1.27^!

What is the character (^) used for?

A good explanation is given here regarding the “^”. In the case of a dry contact switch, I just left the carrot symbol in.

endstops [Smoothieware]

Thanks for the smoothieware lesson. I learned alot. Now to try the different characters to try and get my end stops to work again.

I think I am going to get simple end stops. I have tried several combinations to get them to work.

I got the end stops I thought I needed. They are 3 pin C NO NC. I have tried several times with different charters at the ends of the (1.26^!) with no luck. The end stops have built in leds and they come on when pressed. I took an ohm meter and pressed the lever on the end stop an connected only the two wires that closed the circuit. I connected it to ground middle pin on the board and the signal pin left of ground.

James,

Check, just to be sure…

  1. Between the C and NO wires on the switch, you should read open when the switch is not depressed and short when the switch is depressed. (This assumes that the switch is a dry contact switch and NOT a Hall effect switch. If it is a Hall effect sensor, I can’t help you. You will need to purchase a pair of dry contact switches.)

  2. The Config file that I sent you assumes that Home is in the upper-right hand corner.

  3. If the test in step 1, above, is successful, the connect the “NO” lead from the switch to the “Sig” pin on the LaserBoard. The connect the “C” lead from the switch to the “Grd” pin on the LaserBoard. Repeat the same connections for the second switch. DO NOT CONNECT ANY WIRE TO THE +24V PIN!

  4. In my case. I had to adjust the bar that normally actuated the Hal effect sensors so that it would depress the contact new switches.

  5. The Config file that I sent you assumes that Home is in the upper-right hand corner. The endstop configuration should be:

alpha_min_endstop 1.24^!
alpha_max_endstop 1.25^!
alpha_homing_direction home_to_min
alpha_min 0
alpha_max 500

beta_min_endstop 1.26^!
beta_max_endstop 1.27^!
beta_homing_direction home_to_min
beta_min 0
beta_max 300

Hope this helps,
Pat

Pat,
I got the optical sensors to work but they react different than the regular end stops. I got a config file from Tom who also has optical sensors. I managed to get pronterface to home and work the arrow buttons like it is supposed to. Lightburn will not home unless I keep pressing the home button. It has to trigger the sensors so that it knows where 0,0 is. Here is my modification that works for me. Why do you need anything on the max end stops locations because there is no switch there.
alpha_min_endstop 1.24^!
alpha_max_endstop 1.25 <<< Here
alpha_homing_direction home_to_min
alpha_min 0
alpha_max 500

beta = Y-axis

beta_min_endstop 1.26^!
beta_max_endstop 1.27 <<< Here
beta_homing_direction home_to_min
beta_min 0
beta_max 300

Thanks

I got the config file working the X and Y axis. I was trying to change to many things at one time for things to work correctly. I need Ray or the cohesion3D company to let me know how to wire up my laser. I have not seen any of the posts with the same wiring as mine.

Can any of the screw terminals on the power supply marked L work to hook up to the laser board?

Yes, the terminals marked L and G can be hooked to LASER FIRE and LASER GND (respectively).

The negative wire has to be the one from the end of the laser tube correct?

no, that would be one surefire way to turn your board into an expensive paperweight. Use any of the terminals labeled G on the right hand side of the power supply in the picture above.