From Smoothie to GRBL, no Z-axis or airassist anymore

Machine: K40
Board: Cohesion 3D Mini
Software: Lightburn
Firmware: GRBL-LPC

Problem/ Question:
I run smoothie earlier with after some days of setup run good but slow. To slow in some work.
Get tip about run GRBL-LPC instead so downloaded the 4-axis with Open Drain for Z (external stepper)
https://www.dropbox.com/s/zryx0lc74yjktpi/firmware_grbl-lpc_c3dmini_4axis_odZ.bin?dl=0
But now I cant move Z-axis and airassist doesnt work anymore.

Tried to adjust Z-axis-settings in the tab, no progress
Hooked up every connector from P2.4 and P2.6 and both run M7,M8,M9 and a false work with airassist-button under “Layer” activtated. The output doesnt change on any pin regardless what I do.
The relay that should be triggered is one of the small blue arduino-relay´s thats really common. Tried both with the relay and a multimeter.

Hi Joel,

Were you able to get all your questions answered on the LightBurn forum or do you need any other info from us?

I still talk to Jim about it. There is something strange because it works flawless with Smoothie (but soooo slow). Upload GRBL again and it doesnt work.

So just use our new Smoothie build: Should be as fast as GRBL.

Wow thanks! As I told was Smoothie easy to deal with but to slow. New version is so good!
Everything works flawless.

Thanks for a wonderful firmware

1 Like