Firmware related issue with homing

Machine: completely homebrew machine - 150W Coax laser, leadshine stepper drivers, laserboard and Win10 PC running Lightburn

Board: Laserboard

Firmware: _Smoothie

Problem/ Question:

Machine failed to home, at all. It regarded the power-on position as the home position.

Everything else on the “Gerald” machine confirmed working etc. end stops are hall effect, + and - on X, just - on Y so far and Z ( although the bed is motorised) does not have stops yet.

We have another machine here too “Tony”, which apart from some physical changes and a better laser tube is essentially identical ( apart from using stepper-to-servo drivers and servo motors - which cause grief but that’s for another day…)

After lots of head scratching, we tried the SD card from Tony in Gerald, and hey presto, Gerald homed and worked perfectly !!!( after some inverts had been sorted out ).

The short version of the story is that in order to get everything working we needed to roll-back the firmware from the latest version, to the one installed on our older machine ( which was upgraded with laserboard/lightburn about 18 months ago).

This issue is completely repeatable, the latest firmware breaks homing for us, the older version works fine. Just felt that it might be useful to report this here as the Does Liverpool laser maintenance team generally know what we’re doing, and we were totally stumped by this.

For now, we’ll stick with the older firmware and all is well.

The only real difference we have spotted is that the later firmware mounts the SD card as a USB drive ( which is handy for debugging settings) but the older version does not.

Sorry for not giving the firmware dates in this thread, but neither machine is nearby, if useful I can add the exact versions later this week.

Hope this helps someone.

Sean
DoES Liverpool laser team

Yeah, if you could post the config files and the versions of both firmwares (along with a checksum of the firmware.cur file on the SD card in both instances) that would help us investigate what’s going on. Sorry this is happening!