Firing issues

Machine: _k40 running Lightburn

Board: cohesion 3D

Firmware: _Smoothie

Completely lost as to why my laser won’t fire when I start a project …It’s also not firing from the test button on the psu only firing from panel test button


I don’t see anything connected to the board on the laser fire terminals. On the right-hand side of the board in your pictures there’s a four-pin screw terminal header. One pin is labeled Laser FIRE and another Laser GND. Those should be connected to HL and G on your LPSU, respectively. The +5 and +24 terminals can be left disconnected.

Is this how your machine came or have you replaced the Laser Power Supply? Normally there would be a large white connector that would also be plugged into your board.

Can you show us where the wiring from the Laser Power Supply is going to now?

Yes I did change the power supply to a 60w cloudray …The stock 40w psu Died…I don’t have any wires coming from the board to the psu (That might be my issue) … Here’s a photo

Now @loather’s response is relevant. Please see above.

1 Like

These are the pins I see …Your saying take L AND G and attach them to the top right terminal on the cohesion board that says laser fire…??

In the image above the connector block on the right has six connectors. The printed text above the connector block shows the connections from left to right: H, L, P, G, IN, and 5V .

Connect G (Ground) to Laser Gnd and L to the Laser Fire on the LaserBoard.

The board does not require the 24V nor the 5V wires to be connected.

Diagram Example
C3DLB_PowerConnector\ 305x210 4Pin_PowerPlug_LB\ 260x210

1 Like

Wired it up and still no fire …Now it won’t fire from the panel either

Also my Cohesion3D does not say “Laser Power Or Laser Fire” like the example you showed …I took L and 1 wire from G (There were 2 Wires in “G”) and plugged into the screw terminals on the cohesion board …Clicked test fire from lightburn …No fire …tried Test firing from Panel No fire.

Where’s the black wire coming from that’s connected to the laserboard?

Connect everything back up the way it was before. The connections you should make between the laserboard and the LPSU should be made with new wires directly between the listed terminals.

You need a new wire going from L (the empty terminal) on the LPSU to where you have the pink wire connected on the laserboard, and a new wire from G (currently occupied by a brown wire) on the LPSU to where you have the black wire connected on the laserboard.

Hope this helps …

1 Like

Don’t mean to bug you guys…I’m a Noob at this stuff but when I make the corrections to the connections you stated in your last post do I insert those “New wires” in ALONG WITH the the wires that were already in L and G? or do I take the old ones out and replace them with the new wires I connect to the board?

Add new wires along with the ones that are already there.

still No fire I hooked it up as you stated

1 Like

Okay, in the bottom photo of the LPSU you’ve got the yellow wire in Ground, and the green wire in L.

In the top photo it’s a little hard to see with the angle of the photo, but it looks like the wires may not be going into the right place.

Can you confirm that yellow is going to Laser Gnd and green is going to Laser Fire on the LaserBoard?

Here’s a close-up of your photo. (Again, hard to see with the angle where the wires are going.)

Here’s the diagram and photo that shows what we want to see.

C3DLB_PowerConnector\ 305x210 4Pin_PowerPlug_LB\ 260x210

Hey Pete, confirmed …here’s a side photo they are in the right spot per the diagram

Fernando, obviously make sure your lid is closed, and any safety interlocks are engaged, and then try the following using the console in LightBurn.

Send some lines as explained here: PWM tuning for Smoothie Firmware such as the G1 X10 S0.8 F600

The head should move while firing. A red LED “Laser Fire Status” in the bottom left corner of the board should turn on.

Tell us exactly what does and does not happen.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.