Fire Not working with SD

Machine: Custom 80 Watt

Board: C3D MINI

Firmware: Smoothie

Question: Hello everyone, I have a very annoying problem,I use C3D mini with lightburn,if I use the laser connected to the pc everything works correctly but if I save the gcode by inserting it into the SD when I play you operate the Cartesian movements but not the laser beam. What can this problem depend on? Is it possible for you to solve? thanks to those who can help me.

Hi Alessandro, I’m hoping you can provide a bit more information. I’ve got a few questions about what you are experiencing. And just to confirm, when you run the job the laser head moves through the motions but the laser does not fire?

Do you have a GLCD screen connected to your board?

Are you copying the gcode file(s) to the SD card then inserting it into the Cohesion3D Mini board and powering it up?

How are you starting the laser job?

Finally, are you running the latest Smoothie firmware?

Hello, thank you so much for answering me right away.

Now let’s come to your questions to help you.
I own the GLCD display
I copy the gcode created with lightburn in the SD.
I put the SD in the C3D mini and turn it on.
From the display I go to the work section, select the file and play.
At this point the X and Y axes move correctly but no laser beam is emitted.
I own the latest version of the smoothie firmware with clusters.

If you need more information to help me don’t hesitate to ask.

Thank you very much

Here’s a test you can do. In LightBurn, after you save the g-code file to disk, click the button right next to Save GCode labeled Run GCode. A dialog should open so you can select the g-code file you just created. Does the job run properly (with the laser firing) if you do this?

Yes, if I run the file saved directly from lightburn everything is fine.
Only if I start from the display the file saved on the SD does not start the laser beam

Okay, let’s try another test. Running the gcode file on the SD card from the console in LightBurn.

You can select the file in the console by typing M23 file.gc and then type M24 to run the job.


M23 hello.gc
M24

You should see a result similar to the image below.

If you run the job this way does it fire the laser?

M23-M24

Yes, that’s right…
M20 (gcode list)
M23 file.gc (opens file)
M24 (starts the incision and the beam turns on.)

If I disconnect the USB cable at this point the Cartesian movement continues but the laser beam is turned off

This is an important discovery. If the laser does not fire specifically when the USB cable is disconnected then you have a grounding issue, or more specifically, it sounds like a lack of common ground between board and LPSU. Please show us pictures of your board, wiring, etc…

excuse me but do you mean grounded on the C3D mini?

Yes, that is what I meant by board. Show us pictures of your board, wiring, etc…

Here are the photos of the card, the yellow/green cable that you glimpse in the photo (sorry for the poor quality but it’s all closed in a box) is the grounding. The LPSU power supply is grounded (yellow/green cable).
The C3D MINI card is powered by a 6 A meanwell power supply also connected to the ground (yellow/green cable).
The C3D, on the other hand, is not connected in any way to the grounding (yellow/green cable), the board support is in plexiglass and is isolated from the frame, therefore from a common land.

Do I have to somehow put the ground-connected card?

Thank you for the help you’re giving me guys.

if you need more detailed photos of something in particular ask me as well and I send them to you right away. thank you again

That orange wire there - is that your laser fire line? If so, where’s the corresponding LPSU GND?

Yes the orange cable is the one that commands the laser, it is connected to LPSU pin TL and on the C3D mini card to the FET 1 - pin.
Correct or wrong?

I have a doubt regarding the connection… to the G of the LPSU I connected only the black of the power meter and the jumper to the water pump…is it correct or is a negative missing directly from the board?

1 Like

Now you’re on the right track. You also need a GND connection to the board on the GND pin next to the laser fire terminal. Once you connect that your laser should operate properly.

Honestly, I’m kind of surprised it works at all without that connected! When your USB cable is plugged in it’s using that ground instead.

So that would be that the ground was running through the USB Cable, computer, AC (mains), and LPSU hits that AC. Fun.

When loather and I discussed this matter, I think he was equally amazed that it worked and amused that you managed to use it this whole time without frying anything.

Meanwhile, I have seen this a number of times already.

Excuse my stupidity but I prefer to ask before making irreversible mistakes .

So I have to connect a black GND cable from - of the power supply (my meanwell 6A) to the FET IN - on the C3D mini?

Correct? Excuse me for the stupid question again.

This is the summary pattern of my plant.
Should I connect the GND of FET IN - to the G of the LPSU?

Help me figure out if it’s correct or if something is missing.

Thank you

Problem solved guys.
I connected a GND - directly from the POWER SUPPLY to the G of the LPSU and now everything works.
I had forgotten just this cable.
Thanks everyone for the help, you are the TOP

2 Likes