Engraving Annodized Aluminum

No real discernible difference between noise levels in the nano or cohesion boards. I was under the impression the nano doesn’t do pwm . The cohesion only does pwm. Is that right? Is there a way to turn off pwm with cohesion?

I got some scrap cuts of black anodized aluminum extrusion out yesterday and played with some stuff. Working with anodized is fun!

This is on my 3 year old standard K40, it has analog potentiometer knob with mA meter.

First I did some lines to figure out what power level and speeds would mark the material (as it turns out, the vast majority of them do!)

5mA and a high speed like 400mm/s resulted in a somewhat faded start of the line, but things look good at 7-8mA and are solid at 10mA.

Now to engrave some logos:

The bottom left in this first one was scan + fill. I think it looks bad. The rest are just scan and look nicer.

Next picture. The middle row is 200, 300, 254 dpi. All programmed 400mm/s and 20% in LightBurn of “the pot is set really high", resulting in a real world max output of 5mA. Overscan is on: 3%


Even though I had 400mm/s set in LightBurn, I think the stock acceleration settings were not permitting it to actually get to the programmed speeds.

I tried again with acceleration set to 9000. You don’t have to modify the config file to play with that, you can use M204 S5000 in LightBurn Console to set the acceleration to 5000. Note that your jogging and seeking is going to get really jerky as a result of this, but the rastering went well for me. If you get to that point you can go into config, increase your motor currents, set the acceleration to 3000 or 5000, and decrease the seek rate to 12,000 or 18,000.

Following are my notes from doing this, so won’t sound as nicely written:

20%, 30%, 10% in LB of former pot set high. All 400mm/s with overscan. Accel 9000. Jerky jogging but smooth raster. Need to lower seek rate now.

I think lower power and slowing down may be the way here.

Middle row was (dpi, % power in LB)

Last one looks nice.

That’s in the 4 not quite 5mA range.

Previous notes support findings.

It would be 5mA if it had time to saturate.

I think my middle row, last one on the right, was my nicest result so far.

Btw I did this with the new Smoothie firmware update that we’re releasing shortly that will allow for that level of raster engraving speed.

1 Like

It shouldn’t make loud sounds, at most a slight buzzing or hum.

Glad you are getting nice results! Anything you think I should try different from what I have above?

From what I’m seeing in the output - and maybe I’m off-base here - but your laser seems like it excites just fine at the beginning of a scan then settles at a lower power. That tells me the PWM period might need to be increased - try setting it to 400 in the config file (laser_module_pwm_period 400) and retrying your test.

You are correct in that the nano board doesn’t do any PWM - it’s on or off. To my knowledge there is no way to tell the Cohesion board to “disable” PWM outside of running every job at 100% power in software (which should be a PWM duty cycle of 100%, or a constant 5VDC) and using the pot to control the actual power setting. That said, I wouldn’t recommend doing this as you lose all software controlled power, more or less.

Change one thing at a time. Give the speed/power/dpi settings above a shot and see how that goes for you too.

If it’s an image, use Threshold mode, otherwise just tell it to fill in the vectors. LightBurn will do just on/off in those cases. 254dpi or 300 dpi, and 200mm/s. That might be a good place to start.

I plan to have the high speed raster firmware update released in the next 1-2 days.

And the new firmware update is available now:

So I tried adjusting the pwm interval. 200, 400, 600. No difference. I also upgraded to the new firmware and tried these settings - 254dpi or 300 dpi, and 200mm/s. No difference. Still see the clear marking on the left hand side when I turn off bi-directional. When I change to crosshatch, I see it on the left and the bottom.

I continue to get great results with K40 whisperer. So firmware doesn’t seem to help. Changing settings doesn’t seem to help.

Is there a way to use the cohesion board with K40 whisperer so I can rule out Lightburn as the issue?

No, to the best of my knowledge Whisperer cannot do that.

Simulate the GCode on an online GCode plotter. The GCode for vector scans is dirt simple - it’s G1 moves, with either S0 (no output) or S### where’s the #’s are the power value. That’s it.

It’s pretty hard to screw up, and quite literally thousands of other people are using it, so I’d be very surprised if your specific setup somehow made the software emit bad code. I won’t rule it out, but you could easily enough by posting some GCode here and having Ray or anyone else run it on their own hardware.

I’m still thinking it’s your laser power supply being unhappy with PWM. It gets to excitation voltage at the beginning of the raster line, then for whatever reason can’t maintain it. What’s the datecode on your power supply (if it has one)? Or alternatively, how old is the machine? The older LPSUs were notorious for being shit quality (as opposed to the newer LPSUs, which are merely junk quality).

Filtering the PWM output to an analog voltage could probably be done with a cheap RC filter, but you’d have to rewire the power supply, remove the pot, and supply a secondary ‘on’ mechanism from the board. Additionally, an RC filter isn’t exactly fast due to the resistive and capacitive components…

Can you post your smoothie config file here?

This can also happen, now that I think about it, if overscanning is not turned on. Turn overscanning on and see if that gets rid of the darker piece at the front of the cut. Then play with your settings until you get a proper engrave. edit looking at the pictures again, it’s definitely every time the laser excites, not just at the beginning of each pass. Probably not related to overscanning.

Hi loather. Thanks for the help! The machine is about 5 months old. To me at least. Guess I really don’t have any idea of when it was manufactured. I don’t see a date on the power supply, but here are a few pictures. My guess is that it was made in December 2018.

Yeah, that’s definitely one of the newer ones and it should play nicely with PWM. I concur that Dec. 2018 is probably accurate.

Are you scanning each shape individually or the entire job at once?

Scanning entire job at once. But have tried tests doing each shape individually as well with the same results.

I concur with your assessment - that it seems like the laser excites then loses steam.

I’d point to faulty power supply or laser tube - but it continues to work just fine with the nano board.

I thought about comparing the G-Code from K40 whisperer to the G-Code from Lightburn. But best I can tell, K40 Whisperer doesn’t output G-Code. Which kindof makes sense…that’s why Lighburn requires the cohesion board.

As it stands, I’m just not using the cohesion board, lightburn or lighburn camera for now. It’s too much of a hassle to hook/unhook the board every time I need to make a change. So if there is something else I should try - I’m happy to experiment. But I’m kinda looking at this as 350 bucks down the drain.

The cohesion folks seem pretty non-responsive on this board or to my emails to them about refund.

Pinging this thread to keep it alive and hopefully get some help…Cohesion3d - you there!?

In the meantime - anyone know if there is such thing as y-cables that would let me keep BOTH the Cohesion3d board and the Nano board connected? switching back and forth between the two is incredibly troublesome. And I am afraid that at some point I’ll mess up one of the boards. They’re not made to swap out 2x/day!

Keeping them both connected will blow one or both boards. Electronics don’t work that way.

I still think it’s the power supply not behaving when you pulse the L pin with PWM.

There’s an alternate wiring method you might want to try where you wire the PWM to the top of the pot (disconnect the +5V from the pot and put your PWM on the wire you disconnected instead). You will need to trigger the laser somehow (GND to L) and I believe there is a closure you can use on the laserboard that will do this for you. I don’t know which one - I’d have to get my board out and futz with it for a while.

In the picture above, disconnect the green wire from the laser power supply and attach your PWM output to that wire instead (ignore the part about the white wire where it says, “this is your pwm” - you want the pot inline to control maximum output power). Don’t connect anything to the PSU on the pin you disconnected.

To test this wiring without something from the board driving L to ground, do the following: Craft a job that, i dunno, draws a line or two at 60mm/sec and 100% power or something. Start with the pot at minimum, then send the job to the laser while holding down the test fire button the entire time. Adjust the power until you get whatever your normal maximum power is (15-18mA).

Cue up your actual job on the anodized aluminum, then send it to the laser while you hold down the test fire button the entire time and see if that makes any difference in the output.

Good luck…

I have to turn my anodized stuff to about 30% of 15mA. Practicing with dog tags, was a little out of focus here, but it works fine. Line interval was at 0.050mm @ 100mm/s.

alright, gang…I may be on to something. I accidentally forgot to check the “dithering (halftone)” box in k40 whisperer tonight when I did some engraving. And guess what…the results looked just like Cohesion3d/Lightburn.

This jog anyone’s thoughts around what the issue might be? And is there a way to force “dithering” on all items in lighburn…even text?