Cutting circle

Hello I have a problem with cutting circles and it is oval despite the fact that i set the steps but i am wondering if i may have forgotten something. I have a working surface of 900x900 and I burned at the beginning (y) and moved by 800mm and again burned and measured and I did exactly the same for the (x) guide. Thank you very much

Hi Tomaz,

In the past, you’ve mentioned that you are using Nema 17 and Nema 23 motors, with and without external drivers. It’s a little difficult to make out what motor you have connected to what device, so I will give you a general idea of what to update.

For any motors connected to the LaserBoard onboard drivers (not using external drivers), you can increase your alpha and beta currents in the config file. 1.0 is generally a good starting place, just make sure the motors are not getting hot. More information: Changing Stepper Motor Currents

For external stepper drivers, look at the rating for the Peak current and set your DIP switches on the external driver accordingly, based on the stepper motor specs connected to that driver.

image

Thank you for confirming the bed size. You will need to make some configuration adjustments for that large of a work area.

For the configuration changes to dial in the physics for your machine size, review our Larger Laser Machine Installation Guide, starting with the “Setup” section and working through the remainder of the document.

Once you make the configuration changes, if you do a simple square test that is 100mm x 100mm, at a slow speed like 25 mm/s, are you getting a square that measures this exactly in the output? If not, we would need to also tweak your steps per mm in the config based on the offset you are seeing.

If you need help with the configuration file, please provide a copy for review. Copy and paste it in a reply with 3 backticks ``` above and below the content or paste the contents to Dropbox, Google Drive, or Pastebin and provide the link here.

I now have all silent engines 23 via external drivers
i also set the current to 3.31A

I set the motor steps so that the square is exactly 100x100mm but it is still a circle of oval strength
i also set the curr
only at a length of 800mm now it is not accurate it is about 806mm

Tomaz,

Can you show me a picture of this?

I noticed you are cross posting on the LightBurn forum. Please only post in one place, as you are creating additional work for everyone involved to keep track. This is not a LightBurn issue. It’s either in the settings or mechanical. Try the below test, which is what was suggested on your other post.

Draw four small boxes at the four corners of a large “virtual” rectangle on your workspace, then add the diagonals, like this:

Diagonal_Square_Test

Burn the test on a piece of scrap substrate (using cardboard or something similar, which will cover the majority of your bed), then measure the diagonals. The length of the red line should be identical to the length of the green line.

If the measurement is off, it will affect the accuracy of your output and you will have to physically shift one end of the machine to bring it into square.

1 Like