Connection issues

Machine: K40

Board:Cohesion 3D Mini

Firmware: GRBL-LPC

Problem/ Question:

Not a recent install, has been working great but today it seems to have died.

When I connect to the PC the laser does not work, no connection to GRBL however it does show up as a USB device - Oddly windows 10 identifies it as an ambulo 2400. I have swapped the driver to “USB serial” and still no joy.

I have tried the following

  • Connecting to windows 10 and a rasbperry pi that were both know good for connecting, neither can talk to GRBL. Both can see the laser as a USB device.
  • Checked and loaded the firmware. SD card is working fine, firmware was renamed to .cur. Firmware was known good
  • Reloaded a new firmware from GRBL-LPC for Cohesion3D LaserBoard
  • Tried 2 different USB cables
  • Tried 2 different devices (PI + Windows 10)
  • Checked the PSU is providing a steady 24V
  • Tested with all accessories disconnected.
  • Tested with stepper drivers disconnected.

My LED’s do something peculiar.

VMOT and 3v3 are lit all the time.

L1 is lit when no USB lead is connected and out when i plug it in. Merely touching the USB lead to the case causes L1 to flicker. Other leds only flash doing the firmware update otherwise they remain off.

Note: No SD card inserted in the photo, however it is inserted when testing!

When i connect via the PI i get a little snippet of info that may be useful

Serial ports detected: [{“comName”:"/dev/ttyAMA0"},{“manufacturer”:“LPCUSB”,“serialNumber”:“DEADC0DE”,“pnpId”:“usb-LPCUSB_USBSerial_DEADC0DE-if00”,“vendorId”:“ffff”,“productId”:“0005”,“comName”:"/dev/ttyACM0"}]

This is a video of the weird led issue.

Hi Ryan, thanks for the detailed report. We saw a few things in your description and photos that we’d like to ask about.

  1. You mentioned you tried more than one USB cable but we did notice the one in the first photo looks like the blue one that ships with most K40 machines. We’ve seen these work fine for a while and then eventually fail. If you have a known, good quality USB cable to try, please do.

  2. Is the board isolated from the frame? We can’t tell if the mounting screws are plastic or metal.

  3. Is the machine itself grounded? Is the frame properly grounded as well as the outlet it is plugged into?

  4. For the firmware update, you posted the link to the GRBL-LPC for Cohesion3D LaserBoard, but you’ll want the GRBL-LPC for the Mini instead. You can find that here:

And here’s a link to some other resources for the Mini if you need them:

If you can answer these questions and get the correct firmware flashed, we can go from there and hopefully get you back up and running again.

Hi,

Yes, that’s my spare cable. I usually use a better quality black one but this was just for testing. I have since switched back.

Yes the board is isolated from the frame mounted on plastic standoffs - I had read it was an issue to mount using conductive fixings so avoided that when doing the install.

Yes, the earth was none existent when I got the machine (bolted to the paint not bare metal). I fixed this before the conversion.

My bad on the firmware, I have tried the correct firmware but still suffer the same issue. Windows identifies the device incorrectly and I cannot connect. It’s very weird :-(. The board flashes the status LED’s as expected when uploading new firmware too.

Hmmm, the Ambulo 2400 seems to be an “Ambulatory Blood Pressure Monitoring System” that does connect via USB. Have you ever had one of these connected to your Windows computer? I’m wondering if trying to reset/clear the COM port the Mini shows up under might be worth a try.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.