Connecting cohesion rotary

Machine: cohesion board

Board: cohesion 3d mini

Firmware: could be wrong but I think it’s smoothie

Problem/ Question: I am trying to configure my board for the new cohesion rotary. But I can’t find where to change the delta settings. Not can I find anything on #a axis.

Also, does anyone have the stepper motor specs? They didn’t include any information so I’m not entirely sure what settings to adjust the delta settings to.

Thank you.
I downloaded sublime text.
(I’ll try to include pics down below but I am getting a “low memory” notification when I try to add them

Welcome to the forum! Can you detail the methods you used to find the settings? Like opening config.txt etc.

I downloaded and launched sublime text. Went to open file and I am able to see all the info on the SD card by selecting the “configure.txt”
I see all the alpha, beta, gamma, 3d print extruder, robot arm settings and all that. Just nothing about slot #A or"Delta" settings

This is the screen I get when I open the SD card in sublime text.

The Mini is an older board so we’ll have to update a few things.

First, hardware:

  • Install the A4988 Stepper Driver into the A port on the C3D Mini.
  • On this hardware, the current is not set digitally using the config file, but manually using a trimpot on the driver. When the driver is properly installed, the flat should face outward, towards the closer edge of the board. I would turn it 45 or 90 degrees clockwise, 45 first and do the rest of the instructions, then come back and make it a full 90 if the motor is stalled. You also need a separate power supply powering the Mini if you do not already have one.


  • First, back up the files on your board’s memory card.
  • I would keep the config file on the memory card, but remove any firmware file and put this one on: Improved Raster Speed Firmware Update for Cohesion3D Boards!
    That will serve as both the latest firmware for speed, and also ensures that you have a 4 axis firmware build that supports using the A port for rotary, as it should be :slight_smile:
  • You should add the following section under the Gamma section. I commented out the delta_current line here with a # because it should only appear once in your config file.
# A axis
delta_steps_per_mm 17.77  # may be steps per degree for example
delta_step_pin     2.3    # Pin for delta stepper step signal
delta_dir_pin      0.22   # Pin for delta stepper direction
delta_en_pin       0.21   # Pin for delta enable
#delta_current      1.2    # Z stepper motor current
delta_max_rate     3000.0 # mm/min
delta_acceleration 500.0  # mm/sec²

We have this guide for rotary setup, so take it from here to get your rotary set up and moving.

If anything feels jerky, too fast, or material is flying off the wheels, we can go back and adjust the max_rate and acceleration settings in the config file.

Finally, for LightBurn Rotary Settings:

  • Our large wheels were measured at 50 mm
  • Our small wheels were measured at 28.15 mm

the controller I have already has stepper boards on a and z. will I still go through with swapping the board and reconfiguring the software with the updated info you just listed?
sorry I am not too handy about all this.

this is my controller.

If it has the stepper drivers Ray had mentioned then no need to swap for the same thing.
All the firmware stuff should still be done just to make sure you have most current firmware and configuration.

It looks like you have the correct drivers so the rest is all that is needed.

1 Like

Still not sure what I’m doing wrong.
I’ve added a delta section (copied and pasted yours) tried spacing everything out the same way the other files on the SD card look.
Then went through and changed the c3f firmware via the Dropbox download.
I try to save the SD card but I get an error.
I also included a picture of the blank screen showing the firmware.cur is empty

Do you have the memory card in the computer with a reader?

Yes, I do indeed.

Then make sure that it is seated, try unplugging it and plugging it back in again, and that you can see the drive in My Computer/ This PC…

Yes, it is drive “F”. You can see it in my pics above.

I’m sure it’s something easy that I’m overlooking.
In several of the guides on here that I’ve tried to follow and direct instructions you have given. But some of my screens don’t looks the same as yours. (mainly the firmware screen) so I don’t whole heatedly know that I removed the old firmware and installed the new one properly.
Or if I did the delta settings wrong and that’s why it won’t let me save (showed that error above)

At this point I’d be happy to pay you guys to do remote access to my computer to make sure it’s done correctly. (Knowing my luck I’ll clear the whole card and render my laser useless lol)

How can I get some one on one help. I feel like I’m messing things up here. I engraved something yesterday and it’s all messed up where as it’s always been perfect before. I can only assume I messed up some settings while trying to get this rotary to work. I’d rather not have to return the rotary, but if I can’t get it to work then it’s useless to me.

Thank you.

It might be easier if you just get a new MicroSD Card and put these files from the Batch 3 folder on it:

Get your laser running again, then put the delta section as discussed previously.

i have to be the biggest idiot you guys have encountered. got a new memory card, downloaded and installed batch 3 and the updated firmware link you sent me. laser does nothing. it says its ready. but wont home, move or anything. I would really appreciate some one on one help. I am at my wits end here. and now I have a corrupted memory card. I go to engrave with the original card from you guys in the machine and now my laser is doing extra steps while engraving. (engraving things that shouldn’t be) and the file was created in lightburn so I know the file is good. I know ive never claimed to be experienced in any of this (rather the exact opposite) but I know this is supposed to be easier than it is on my end. sorry to be such a huge pain. but I would certainly appreciate some help. (not that you aren’t helping now, but so far nothing you have instructed me to do has worked) but as it sites I have customer orders waiting and a laser that’s in error state.
Thank you

So I’ve downloaded from the Dropbox links you gave me above. Bought a new sd card and transferred the files directly to the SD card (after formatting the card)
Then put the card into my laser.
When I plug in my USB into slot #g it pops up and I can see the files are on it.
However the laser still doesn’t work.
What am I missing or doing wrong?


Meaning you copied them from the dropbox link I provided to the new card, yes?

So when you plug the board’s USB cable into the computer the drive shows up?

One more thing to check, can you confirm what each of the lights on the board are doing? Pictures help.

Yes, I downloaded the files from the Dropbox link you provided.
And yes, when I plug in my laser cable and it pops up as slot #g and I can see the files are on the card.
(With laser machine off. I get lights 2,3 stay steady on, 4 and 5 blink rapidly, 6 stays steady on. (All of these are green)

With the laser on. Light 1 stays on (red)

And what is the file called on the memory card now? Is it firmware.bin/ firmware in lowercase or is it FIRMWARE.CUR FIRMWARE in uppercase?