Config file for TS4060


(Christophe Dekeyser) #1

Can anybody help me to place the settings/parameters for my TS4060 in the config file?


(Ray Webster) #2

goto this thread, Alain posted his changes which mostly worked for me. I also had to increase the amperage for the motors to 1.2


(Christophe Dekeyser) #3

Hello,

My machine is flipping it doesn’t know what the working place is on the bed, it moves up with a noise from the servo y-axis x axis seems no problem, my steeings are 600mm x 350mm.
Further seems everithing oke. Is there a copy of config that I can use for my TS 4060?


(Starla Fox) #4

Hi Christophe,

Please explain what you mean by flipping. Is it sporadically moving or going in reverse?

Updating your profile with your machine/controller/firmware helps us troubleshoot more efficiently. If you’re using GRBL, report back. Otherwise, setting the bed size is covered in the following FAQ:
https://forum.cohesion3d.com/t/setting-up-the-correct-bed-size/492/2

You may benefit from adjusting other settings outlined in the link Ray provided above. Try exchanging the parameter values listed to the right in the example excerpt and adjust until fine tuned: Chinese TS 4060

Start here and we will work our way forward with the next steps, if needed.


(Christophe Dekeyser) #5

Hi Starla,

I tried to make a simple square, I placed in Lightburn in the left upper place, then I started it and the laser goes more than double speed in a not nice work with silly lines, and a noise from the servo because it is out of the workplace my setting are 600 x 350 mm.my home position is left top but i Lightburn I set it to left front.


(Starla Fox) #6

Great, let me know if you are still having issues with the speed and noises after making the recommended config file changes.


(Christophe Dekeyser) #7

Hey Starla,

I just put the C3D back with the settings, but now my machine doesn’t find my home when I press the home button in Lightburn than the machine goes a little right and a little down. And when I give the command to go to 0,0 then it goes down and press the head against the metal bar with a noise than comes from the servo.
What can I do now ? :frowning:


(Christophe Dekeyser) #8

Starla,

I am sorry, I forgot to connect the white cable now it goes to home and 0,0
Now I must search to set the parameters for burn and engrave because it goes very fast in engrave, I thank you for your help, and maybe you can advise me for the settings for cut and angrave without get all the power out of my tube :slight_smile:


(Starla Fox) #9

Good to hear, Christophe!

For LightBurn settings, the line (cut) and fill (engrave) settings will vary. For engraving, you can realistically go about 80 mm/s with Smoothie running GCode, theoretically slightly more (100 mm/s). If your speed is set higher than this in the layer settings, try reducing them to fall within this range. For cutting, you would need to go considerably slower, depending on the substrate you’re working with.

image

If you are running within this range and still experiencing this issue, please post a screen shot or link to a copy of your entire config file, so I can confirm what your parameters are set at to help troubleshoot further.


(Christophe Dekeyser) #10

Hello Starla,

After one week everything works great, only my home postition (left top) is hard, it smaches with the endstop against the blauw metal, I thiunk it is not a big problem, but my endstop switch will soon be damaged I think, is there a solution for?
You helped me a lot thanks for all this.


(Starla Fox) #11

Hi Christophe,

Use M119 in the LightBurn console to verify your switches are being read, as explained here: https://lasergods.com/testing-k40-endstops-with-lightburn/

image

You may also want to check all of your connections and ensure nothing has come loose in your wiring.


(Ray Webster) #12

I also had this, I slowed down the rate at which my machine homes.


(Christophe Dekeyser) #13

Hello Ray,

Where did you chance the values to slow down the homing?


(Starla Fox) #14

Hi Christophe,

Try decreasing the fast homing value in the config file to see if that resolves the issue.

alpha_fast_homing_rate_mm_s adjusts the speed in millimetres/second (X axis)
beta_fast_homing_rate_mm_s adjusts the speed in millimetres/second (Y axis)


(Ray Webster) #15

I was at work when i replied about changing the speeds. Starla Fox has given you where to change it. I believe I slowed it down to 100mm. As I only home the machine once, when i start it up, It really doesn’t matter how slow it gets there. But this stopped it from crashing into the limit switches .


closed #16