Computer Not Seeing Laser - Was working a few weeks ago

Machine: K40

Board: Cohesion3D laser board

Firmware: _Smoothie

Problem/ Question: Everything has been working. Haven’t used the laser for a few weeks and went to do a job today and the computer isn’t seeing the laser at all. I have tried multiple USB cables, ones that I know are working from my vinyl cutter and my printer. I even tried connecting it to my Mac instead of the dedicated Windows 10 machine I have it hooked up to. Neither machine sees it. Lightburn just says waiting for connection. Its not even showing up in Windows Device Manager. The board is on and blinking and I can manually move the laser and home it with the LCD panel and pot.


Hi Andrew, I noticed in your first photo the power supply is not plugged into the LaserBoard. Was it plugged in and getting 24v power when you tried using it? I’m assuming maybe you just had it unplugged for this photo since you said you could jog the laser around with the GLCD.

Next, have you tried to delete your device (click on the Devices button to see the list) and manually re-add it?

If it still does not connect you might try the following:

Power off everything, then unplug all the cables, make sure none of them are in contact with the LaserBoard (or anything else, tape over any ends if needed so they do not contact anything metal). Now with everything unplugged, plug in the LaserBoard power supply. Check the LEDs on the board, they should look like what is listed under “Normal Operation” on this page:

If you do not see the Normal Operation LED sequence, make note of the sequence you do see and compare it to the others listed on that page.

If the LED sequence indicates an issue with the firmware or memory card, shut everything off again and remove the SD card, insert it into a computer, and make sure the card is readable and has FIRMWARE.CUR and config.txt on it. (If the card is fine, return it to the LaserBoard.)

If you are seeing the Normal Operation LED sequence and the SD card is good, you can start adding the things you unplugged - one at a time - and you should unplug the power for the LaserBoard before plugging anything in. For instance, unplug the LaserBoard power supply, plug in the X motor cable, plug in the LaserBoard power supply, and check on the LED sequence. Repeat this process with each of the components, powering down, plugging in another one, powering up, and checking the LEDs. There may be one failed component (bad endstop, shorted out motor) that can prevent everything from functioning properly.

The power is hardwired in and not using the plug. See below photo.

I took off all the connections so it was just the board and still nothing. All the indicator lights were exactly as shown in a normal operation for the board. See photo. L2,L3 were blinking. The board still isn’t showing up at all in the device manager or software.

I deleted the connection in lightburn and tried find my laser as well. Its not seeing anything at all on any USB. I tested my computer USB by hooking the same port and cable to my vinyl cutter and it worked fine.

Where are you powering the laserboard from? I see you’re using the terminals on the lower corner of the board and that’s completely fine - but what is actually providing that power?

The 24 Volt power supply I got with the board from you guys.

clever - i was expecting to see the end chopped off the cable and it reduced to bare wires - the internal barrel jack with leads is quite nice.

OK, do something temporary for me real quick - disconnect that barrel connector and leave everything else disconnected. you’ll see a jumper above the row of 2mm JST external stepper connectors. It’s labeled 5vREG or USB - move it to the other position and plug the USB cable into your computer. report back what happens.

We don’t want to leave it this way permanently, so move the jumper back to the 5vREG position when you’re done with this quick test.

The board powers up and I get blinking lights, but the top is green not red. Computer still doesn’t see the board.

Now what can I do?? This board is practically brand new with very little time on it because of slow business due to the pandemic. Now that I have a job I am jammed up. I am suspecting there is a hardware issue with the USB data line since at least we now know its getting the 5V.

If the status LEDs are showing it as working as you state above, let’s try flashing the firmware:

Refer to the instructions at the very end of the LED guide to reflash the firmware and see if that clears up your issue.

So I reformatted the SD card and dropped the firmware files on it from the link. (The card looked fine when I put it in my computer before reformatting it by the way. Files were there.). Put the card in the board and turned it back on. Everything comes up on the LCD screen just fine. Computer doesn’t see it. So I powered off the computer and then back on hoping maybe that might reset something. Still nothing.

OK, thanks for verifying that. Ray’s in contact with you and should have a resolution for you shortly.

Thank you for doing these tests, I will reply to your email to arrange a resolution in a bit.

I didn’t get an email. Can you resend please.

Sorry, I was going to send you a replacement board yesterday but things got crazy with the hurricane. Pretty much, I’m going to send you a new board. The email was going to be that it shipped and instructions to return the old one. I’ve just entered the details for your replacement into our shipping system.

Great!! Thank you very much.