Cohesion3D usb dropout

Hi all.Sorry about the essay but I need HELP. I am getting communication dropouts that stop the machine. when things in the house turn on or off. I just installed a C3D laserboard (Not mini) running Smoothie and Cohesion 24v power suplly into a K40, the one with the ribbon for X and limit switches and the red stop button .My setup is 240V -Stock K40 PSU with all possible load removed(New),a small airbrush compressor for air assist not activated from the board yet.(manual). 24w pond pump.not K40 stock one. 12V extractor/bilge fan that is separately powered and switched.I have tried Different usb and 240v cables, running different components from different power feeds from the house fuse board as well as running on UPS. Tried running C3D 240v supply from Disconnected UPS-No connection to house power.
I get a dropout when things turn on or off (fridge or Compressor)with no stepper motor movement or with then going flat out. All help or suggestions would be greatly appreciated.FB_IMG_1549088726304|281x500

Try running the power to an outlet on a different circuit, even if you have to run an extension. Line noise from other devices or a bad connection in your electric system can sometimes cause problems. You can also try using a powered USB hub, this has solved problems for some. Did you also connect the computer to the UPS?

Have tried a different circuit. Next step is to through an extention lead over the fence, but the board conected to a disconnected UPS should have given it clean power . Have tried diferent USB ports. Have not tried a Powered USB hub though. or the PC on UPS yet.Wouldnt have thought it unnessesary as it will run 3d printer and plotter OK??

Please update this as you figure things out. I’m dealing with the same issue as well and having a hard time getting it worked out. But it’s very annoying have to start jobs over all the time.

Jake.
Few questions please
What Tyoe of PC are you using ?
What OS do you have?

  1. What type of USB cable are you using.? If you still have the blue on bin it and get a better quality one

2.Switch off all electrical equipment in your workshop, see if the problems goes away.

  1. Make sure that windows takes no action when the USB cable is plugged in to your machine.

Could also put a few pics up of the electronics bay setup. Including front panel and general layout of the PSU.

It’s more than likely you windows that is shutting the USB off so disconnecting you laser. Do that one first and see what happens…

1 Like

@JMLaser206
Josh,
Same question to yourself as I have posted for Jake.

I’d you could answer those genus please ?

1 Like

@Jake I have been keeping an eye on this thread both here and on FB. If all else has not helped, you can also try the GRBL-LPC firmware for laserboard: GRBL-LPC for Cohesion3D LaserBoard

@JMLaser206 Josh - there are some additional considerations for Mini that I can provide you, I will comment on your other post as to not mix streams.

@Jake

I understand that you are using Smoothie and the problems appear to be happening when doing pictures with speeds of 200 mm/sec.

There are limits to the smoothie in Data transfers rates so would recommend going over to Grbl-lpc.

Other things to look in too is your PC software may be accessing the USB port and killing the connection.

There is also an issue with some PC’s and shuts down the USB after a period of inactivity of the PC.

Would be good if you could give us some feed-back on here.

Hey! I have been waiting for a reply over on my thread, but have yet to see anything. Just making sure you didnt forget about me! :slight_smile:

Haven’t forgotten - just a bit swamped with work and need a bit more time to compile the info you need.

Update.Trying to do grey scale photos with Lightburn. Each time has several attempts to confirm repeated results. K40 will just stop randomly. Desktop PC 64 bit Intel 7i 3.07 Ghz with 12 GB ram running windows 7.
*Pc -all power saving off no screen saver and USB on permanent ,all made no difference- Fail.
*Different USB ports-Fail.
*New waterpump.-Fail
*Repair earth to case and rewire Power inlets and outlets-Fail.
*PC and K40 and board 24v power supply on UPS, -Fail.
*Ferrite beads on all leads- Fail.
*Bata only SUB cable- Fail
*Smootie down to 100mms -fail.(if anything got worse as had more time to fail.)
Switched to GRBL at 100mms -Fail, at 300mms Fail (also no evidence of Grayscale).
*Out of ideas!
*REFIT NANO2 board and use Corel Laser.(only swapped board and running off K40 psu) 5 different runs worked every time @ 100mms,200,300,400 with different laser % over 2 hrs burning -Sucsess.
Cant do grey scale or use lightburn but it doesn’t ruin 9 out of 10 jobs.
C3D Any more Ideas??

@Jake
Jake,
Just to give you an insight to why I am involved is I had the same problems that you are having so using my experience in helping you out. I may be asking similar questions to others as it’s difficult to work through what you have already been told and what sequence of fault finding you have done them in.,

As for switching back to the M2Nano I can share your thoughts as saying its the Laserboard that’s at fault, but put plainly the M2N doesn’t have the same problems due to the software transfer and not control the PWM for the laser. So the laserboard is receiving so much more data than the stock board.

Is there any chance of some pictures of your set up with what/how you have running please?

You say “different USB ports”
Ones on the front or direct to the back?

Also is the USB ports on the back connected direct to an expansion card or are they on a wire connecting to the motherboard?
The wired USB ports are renowned for picking EMF up and causing problems to fast data transfers

Do you have a GLCD fitted?

How far away is your set up away from your house?

1 Like

Hi all its time for a bit of an update,

Eamonn I appreciate any and all help given. Thanks to all who have chimed in.
I don’t have a lot of spare time to work on this laser so my updates and replies are a little while coming.
I will post some Pics of the setup as soon as I get a chance.
Different USB ports are in front wired to motherboard, in back directly on motherboard and about 8 different ones USB 2.0 and 3.0.
Not running GLCD as I will probably run GRBL more than Smoothie when its reliable.
Unit is located in rumpus room in back of house. All power points are 3 meters away and there is nothing in the walls around it. Powered by UPS and extension cord to unit.
Water pump sits on a shelf next to the laser and Air compressor is on floor about 1.5m away.

Have stripped and rearranged wiring and power supply positioning in box as well as fitted board controlled air assist solenoid. I am running tests as I type this.3 hrs in and so far so good. Fingers crossed.

Bit off topic but I Cant seem to get GRBL to grey scale at all. Read somewhere it needs a different wiring setup (M4?) . Anyone know how to do this?

Thanks

2 posts were split to a new topic: USB Dropout Problem