Cohesion3D Rotary / Lightburn not working correctly

Any more thoughts on this?
I tried changing variables today like the delta_steps_per_mm … but nothing seems to work. 17.77 seems to be the only number where I get a consistent squished square.

I thought Oz got you sorted on the LightBurn forum thread where he explained that everything appears to be working as it should.

Yes, that is wasn’t a software issue, but I’m still getting “squeezed” squares.
For example, a 10x10mm square in Lightburn comes out as 10x8.5mm when on the rotary.

Here’s another test I did tonight that compares what I’m getting, compared to what Lightburn is showing.

Here’s my A axis settings. I really can’t see what I’m doing wrong here.
Is it possible to test the rotary on the Z port, to see if this is a port issue?

A axis

delta_steps_per_mm 17.77 # may be steps per degree for example
delta_step_pin 2.3 # Pin for delta stepper step signal
delta_dir_pin 0.22 # Pin for delta stepper direction
delta_en_pin 0.21 # Pin for delta enable
delta_current 1.2 # Z stepper motor current
delta_max_rate 3000 # mm/min
delta_acceleration 500 # mm/sec²

Yes, swap all the delta_* values for the corresponding values found in gamma_* and that will swap the Z and A connectors.

Good luck …

OK, tried as suggested and placed it on the Z port and swap over the numbers.
I did a no burn test ans it looked like it wanted to engrave diagonally. I tried changing the “mm per rotation” away from 360 and now the rotary won’t spin at all. Even when I changed it back to 360, the rotary will still not spin using the z port.
Set everything back to A and it seems to be working as it was before.

Is it possible that Laserboard is causing the problems? Is there any way to trouble shot/test the board?

Short of a stepper driver problem, it’s likely not the hardware if you’re getting as far as you are. One test you could perform is to use an external stepper driver to run the motor - that would rule out the embedded driver as the problem (but it’s unlikely it’s the driver).

The motor provided with the rotary is supposed to get 1.2A and you have it configured properly, speed and acceleration is very conservative - I’m not sure where to go from here. It looks like the motor’s consistently losing steps on some motions, but without a rotary here to play with personally I’m not sure how much more help I can be :frowning:

  • If you have calipers, you can verify the outer diameter of the rings on the large drive wheels to confirm it is close to what we are expecting.

  • The G0 A360 verifies the board is doing everything properly.

  • The max rate and acceleration values can still be reduced further to really slow it down.

  • Something I learned is that light objects such as pencils (and your hollow tube) can bounce a lot when being spun, even if being spun slowly, this is what the tension arm is ideally for. Slow it down as above.

  • Draw a narrow and tall rectangle in LightBurn where the height is the circumference of your work piece tube. Run it. The top and bottom lines should burn on top of each other. Off the top of my head I think that’s how it’s supposed to work.

A.) Yes, the rubber rings are about 50.20mm on my calipers

B.) “G0 A360” doesn’t do anything, while “G0 A360 F120” turn 360 degrees very slowly.

C.) I the attached pics, Number 1 is at the above rate/acc, Number 2 I’ve dropped the rate to 1000 and acc to 100 and Number 3 I’ve dropped the rate to 500 and acc to 50. As you can see the results are the same.

D.) I switched the cardboard tube to a much heavier glass jar as you can see.

F.) The rectangle the length of the circumference doesn’t meet up as you can see in the picture.

Anymore thoughts on this?

Adjusting steps per mm until the two lines line up will help - marginally.

Are you using the hold-down?

It really does look like the rotary stepper is repeatably losing steps for some reason. Can you get a video (with sound) of the rotary as it burns that test image?


Yes, this is what I meant, just shorthand - the fact that the the rotary spins 1 full revolution when commanded to do so suggests that the board is configured and operating properly.

No, the steps are correct as they are, see above regarding making the full revolution.

In the “full circumference rectangle” example, if you have just that rectangle in your job (or set anything else in the LB job to not output so only the rectangle is being output), then save the gCode, we can take a look at that here. We want to find the long line that goes around, and see what the coordinates that A is commanded to. If you upload that file and give me a link here, I can take a look. That A values should be just around 360 degrees.

The simple solution is to just scale your “Y” dimension in your designs up by a factor that gets you a full revolution and see if that is consistent/ repeatable.

As far as the stepper motor skipping, if you upload a video with audio of running said job, I can tell you if it is happening and it might help spot if there are any other issues.

For reference on object weight, I spin a full wine bottle on each rotary as a test.

So I did another G0 A360 test and still get 360 degrees of rotation.

Here’s a video of the rotary doing a frame outline:
Here’s a video of the rotary a no power burn.
Note that I clipped the mic right next to the rotary motor, so it should pick up any sound it makes.

I did the math and scaled up by 101.54% , which should cause the lines to meet, and this is what I got:

You can see that it now overlaps the still shifts on the Y.

Here’s the Gcode:

; LightBurn 0.9.07
; Smoothieware device profile, current position
G00 G17 G40 G21 G54
; Cut @ 5 mm/sec, 8% power
; return to starting pos
G0 X2.5A-242.64

Is it possible this is a board issue and not the rotary or Lightburn?

Anymore thoughts on this?

Unfortunately those videos don’t show much in the way of what I was looking for. Can you do a video with the test pattern you were trying before, with the shapes and the text? That should let me know if there’s a problem with it reliably skipping (hopefully).

The longitudinal offset you’re seeing there is because the jar is moving on the rotary. The rollers are sitting directly on the glass on one side and on the tape on the other. It’s almost certainly walking back and forth because of that.

As far as the two lines not meeting up, there’s still a little tweaking you need to do with the scaling. It’s real close :slight_smile:

OK, here’s the video with shapes and texts:

Without power:

With Power:

So, I spent a bunch of more time working on this and testing.
The only thing that seems to make a difference is unchecking “Optimize Cut Path” in LightBurn, which seems to give results that are more the correct proportions, but does add other issues.

I think I’m at the end of my ability to troubleshoot this. The deformation you’re seeing there I thought was consistent stepper skipping, but after listening to the videos and not hearing what I was expecting, I’m unsure. could you post your entire Smoothie config file?