Co-ordinate issue

Machine: Chinese K40, do not remember the board, it was the stock board

Board: Cohesion 3d mini
Firmware: Smoothie

Problem/ Question: I am having issues with the coordinate system of either the machine or the firmware (or both). It has issues as to where “Home” is and “Origin”. Especially “Home”, when I turn on the machine and the software (LightBurn) and tell the machine to go “Home”, it moves to the bottom of the work area and chatters quite badly, but (most of the time) when I then tell it to go to “Origin” is seems to move there just fine, but in relation to the actual position strong on both the “X” and “Y” positioning. Sometimes I can get it to work well, by turning on and off both the system, repositioning the gantry manually, but as soon as I turn the system off, both the machine and the software, and turn it back on, more often that not it goes right back to the same issue. Now as far as using the move command built into the software there is no issue, except the coordinate call out as to where the laser head is at the time I finish using the software to move it around. I hope somebody can help, by the way I have had issues before, but with “Jogging” during engraving, new belt and a lot of time fine adjusting is solving that issue. Thanks for the help there. Any help here will be greatly appreciated.

First question:

Does it home correctly? It should go to the switches in the rear left corner, touch them (it’ll back off and touch them again slower), and then stop.

hi thanks for replying know it doesn’t home correctly I went through the process to make sure the switches do work and they do but for right now what’s happening is sometimes I can adjust it somehow turning machine on program on and off and get it to work and then when I turn the everything back off and then turn it back on it doesn’t work again homie seems to be down in the lower section middle of the workspace run Oregon doesn’t work at all really so I’m not sure again if it’s the firmware the chip that’s in there or what it called the memory board or the machine itself again any help would be appreciated

I carefully read your wall of text, twice just to make sure, and I don’t see an answer to Cohesion3D’s question anywhere in there. Does your machine move to the limit switches when you try to home it?

It’s a separate issue from whether or not the limit switches are in working order.

1 Like

Again No, the machine does not “Home” correctly. As stated when I try to “Home” the machine it moves the Laser Head to the middle of the “X” axis and the very bottom of the “Y” axis. I have been told the G28.2 XY command should have the machine “Home”, I will post the results a little later. Also, when I use the LightBurn move buttons to move the Laser-head to the limit switches and then back off 10mm in both the “X” & “Y” axis, then call for the “Get Coordinate” function I get something like X = 10, Y = 440. I hope this makes things a little clearer. As a follow up thought, could the, for lack of a better term, the Application file on the microchip have become corrupted? If so where can I find a “Clean” file to copy and paste onto the chip? Thanks for the help

I have ran the G28.2 XY command with the laser head somewhat in the middle of the work area, I will insert picture of Consul Screen and a link to the video showing the laser head movement upon entering the command.

, and the link for the video is https://youtu.be/1S7150yF1Lg

Based on this video, I can confirm that your machine is not homing, but instead thinks your switches are already pressed for one reason or another. Are all your cables connected to the C3D Board? If the endstops were unplugged, this would happen.

In a previous interaction, you had the endstop cable unplugged. Is it plugged in now? Please show me pictures of the board with wiring as it is now :

Hi: the following picture was taken today, I have one bright red light at the bottom and 4 green light above, with the 2 middle ones blinking. The picture also shows that all (including endstops cables) are connected.

The following pictures are sequenced, the first picture shows where the gantry is when it is supposed to be at home and the 2nd picture is a screen shot of the “Get Position” X,Y called out X = -10.0, Y = 420:

The next sequence show the gantry at “Origin” with to corresponding picture of the “Get {Position” X = -40.0, Y = 0.0:

The only thing I did per instructions from a helpful tech was to find and download 2 batch files for clean “config.txt” files (he stated to obtain help here on the forums before trying to do anything with them and the machine), and earlier edited the original “config.txt file” to reset the work are size by changing the beta_max (under endstops) to 210.

Still I am having trouble getting the machine to move the gantry, via the “Homing” and Origin" commands, it seem to just do what it wants to do.

Again any help would be greatly appreciated, thanks

Hello,

I have posted additional photos and description of me issue, please review and let me know what steps, if any, that I can start to take to solve the issue.

Thanks
Mark

Use M119 as shown here to verify that they are being read, and read correctly. 0 means not pressed and 1 means pressed:

Sorry for the delay, I went though the advised process’s listed in the previous post, and to a certain extent it did work. I found that the connector to the board was loose. I pushed it back in and the unit “Homed” and “Origin” correctly. I then proceeded to Hot Glue the connector down and test homing and orign again and it seemed to work, see picture below:

I then went on to do a test engraving, it seemed to start properly but wasn’t making any burning on the wood.Should have started the engraving on the bottom left corner, see picture:

So I stopped the process and sent the unit to home, which the unit went to the middle of the X-Axis work area and to the top of the Y-Axis work area, see picture:

Using the programs “Get Location” feature the unit thinks it is at X = 0, Y = 220,

I manually reset, via the move command for the program, moved the unit to where X = 0 and Y - 220 should be, and the “Get Location” featured showed that the unit was at X = -60, Y = 220 :slight_smile:


I readjusted the speed and power and started the engraving again and the unit was supposed to go to X = 10 & Y = 10, it moved to X = 60, Y = 10 and started to burn. After a few passes, it stopped engraving and went back to the top center (see earlier picture). Went I tried to go to Origin from there it went straight to the bottom center of the work area and chattered for a moment (note: just to the left pf the head you can see the very light burn work and the actually size of the burned area (1/4 the size of the actual area to be engraved):

Then from there I tried to send it home again and not only did it return to the center top, it in fact moved a little more to the right.

So again, except for the fact that the unit seems not to be running into the gantries any more, I am still having issues with the co-ordinate system being very non-consistent. Thanks again for all the help

PS: I have 2 clean config files for the board,however I am advised to obtain some help from this group before attempting to utilize them.

Device origin is different than home. Device origin (0,0) is bottom left. home (where the endstops are) is 0,200. make sure you have device origin in lightburn set to bottom left and not “home”

Good morning, thanks for the review. Yes, I have made sure that the board and the program (Lightburn) are set to the proper “Home” and “Origin” co-ordinates correctly.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.