Cheap diode laser upgrade


(Gary Webb) #21

for grins, I swapped the Y motor onto the X motor driver, and the problem seems to follow the motor. Maybe my belts are too tight? Strange that it moves quite smoothly on power up though.


(Gary Webb) #22

This is the original board the motors were connected to. I noted the pinout and X1/Y1/Y2 connectors. Am I missing something? I’ve tried using clip leads to experiment with the pinout on the c3d board, but I started getting a little uncomfortable jumping the pins hot, so I stopped. Can anyone confirm the pinout on the cohesion board?


(Gary Webb) #23

I went through all the docs/forum last night and I found a few tidbits that were interesting.

  1. Due to having two Y motors, there may be an amperage/voltage difference from the X motor.

  2. Don’t jump pins when the board is powered up. Luckily nothing bad happened to my board, but for all you new installers… Don’t mess with the board when it has power!

  3. If you’re using a diode laser and utilizing its 12vdc power adapter in addition to the C3D board 24v, remember to power down the 12vdc adapter BEFORE you power down the c3d board 24v. Otherwise the laser comes on and stays on till the 12vdc adapter is disconnected.


(Gary Webb) #24

Running out of ideas. Im curious if the issue is something I need to address in the firmware/config or if this is something i need to address in lightburn. Also, at this point, this topic has become a post-sales/hardware installation topic… So if the mod’s want to move it to another thread, or if i should post further information there, please let me know, and I will do so.


#25

You will need to change some settings for sure:

I would decrease the Y acceleration and turn the currents up to 1.2 amps as discussed there.

You also need to verify that you have the 2 Y motors plugged in with the proper orientation to each other. Based on the videos it looked like you already got this, but I would test it by having both motors plugged in with each other, but not to the board. Then try to move the Y axis by hand. It should move relatively smoothly, and you should not feel a braking or binding force.

Ah, the joys of the Chinese no pull down resistor!


(Gary Webb) #26

I will try these settings and report back. Also, I was thinking it would be easier to plug my second Y motor into the AZ Axis pins and set the jumpers so that Z follows Y. Is there any documentation on this? Or do I just need to move all three jumpers over to follow?


(Gary Webb) #27

I was going to make a joke about smoke and fire… but thought it was in bad form. Rather I’ll just say, it works! Changed current on xyaz to 1.2, and lowered acceleration to 1000. Now the gantry is moving forward and backward as expected. Now I have to figure out if the laser fires :smiley: I have two remaining questions.

1 - How can I setup the ZA pins to follow Y? Do i just move those three jumper blocks over?
2 - I recall seeing a thread about having a test laser button for focusing the diode. Can you elaborate or tell me which search criteria i should use to find the solution?


(Gary Webb) #28

The gantry moves… But seems like its moving rather harshly and suddenly. It shakes the entire bench I have it mounted to. Should I turn the acceleration down further?


(Gary Webb) #29

I think I figured out the pins/jumpers. I just moved all three over. I had to flip the orientation of the secondary Y motor cable (quick fix) to ensure the motor operated inverse to the Y1 motor. I also turned down the acceleration and the seek rate. This minimized the amount of shaking my bench was doing. Now to test the laser. Wish me luck!

p.s. any plans for a wireless or ethernet adapter for this board? :smiley:


(Gary Webb) #30

welllllll… sort of worked? Didnt cut/engrave/burn anything… Diode comes on, but doesnt appear to do much… The gantry goes completely berserk though… see video


(Gary Webb) #31

I will say, we’re getting closer! Then I can tear it apart, take pics of the steps taken, and submit for future generations.


(Gary Webb) #32

And seriously, how much money did they save by skimping on a pull down resistor?! Pennies?

Ah, the joys of the Chinese no pull down resistor!


(Gary Webb) #33

I figured it would be easier for me to upload my config.txt for review. I’ve been tinkering with acceleration and seek speeds. Seems like 2000/3000 is way too fast. I turned it down to 1000 and it is now much smoother. The remaining issues are that the laser wasn’t engraving or burning when it was firing. I dont know what it was. I changed the min laser power setting to .2 and that is too much, because now it fires while jogging/moving manually :smiley: I guess I’ll have to turn it back to 0. So I think what will need to happen, is setting the min power back to 0, and max to 1.0? 2.0? I cant remember what it is in the config at the moment. And from there I’ll need to decrease the seek speed down to like 200 or 300 so that it actually does some damage to the wood :smiley: Another issue is that the unit doesnt seem to know how to go back to the origin I’ve set. It seems to think its at -20 on Y and 0 on X when I have it in the front left. This might be due to the lack of limit switches? Lastly, I attempted to burn a 1"x1" square (25.4mm x 25.4mm) and for some reason, its actually cutting exactly double the size. 2x2 or (50.8x50.8). Neat? Maybe not?

http://www.esacjack.com/laserpewpew/config.txt

In regards to the laser firing when tracking, I did find this thread which talked about the same issue, which is what led me down the path of turning the min power down to .1


(Gary Webb) #34

Correction! The laser thinks its at 160 and -40

image


(Gary Webb) #35

I ended up having to turn the min power back down to zero. I have turned the acceleration down to 200 which is what the cheapo knock off nano was set to originally. Based on my experiments, any faster, and I begin to see striations in my burns. Oh! And in case I didnt mention it, I have successfully run several burn tests! So progress is definitely being made. I have some googling to do today to try and solve the homing issue, which im almost certain has to do with no home sensors/limit switches. I was also caught off guard by the fact lightburn starts its burn in the center of the workspace, regardless of where I position the image/text. It is still burning images twice the size of what it should. Which I’m guessing is buried in the lightburn settings somewhere. To circumvent the issue of the laser firing when being powered off, I setup a American DJ PC4 to control my light/24v/12v adapter. Much easier than just unplugging a cable. In the long run, i’ll probably use some smart switches/strips and setup automation to power down the 12vdc before the 24vdc.


#36

It’s going to take me a bit more time to read through everything here and get back to you.


(Gary Webb) #37

Sorry… I’ve been using the forum as my notepad obviously :smiley:


#38

Working through this… slowly…

Homing? You need endstops installed otherwise it won’t work.

Depends on origin and start/ end position settings in LightBurn.

Probably steps per mm values in the board’s config file. Start by telling the machine to jog 100mm in each direction, and measure how much it actually moves.


(Gary Webb) #39

It definitely jogs 200mm when telling it to jog 100mm… ill have a look at the config file now that im done traveling for a bit.


(Gary Webb) #40

ok so which section of the config do I need to change? I see steps per mm, but seems to indicate cartesian robot, and I see A/B/C steps per mm. I assume its the ABC? or is it the alpha/betta/gamma steps per mm?