C3d mini with external power suply

Machine: k40

Board: c3d mini

Firmware: “I have a new board and I’m using whatever it came with” is also a great answer!_

Problem/ Question: hi all! Ive upgrades my k40 gantry to 700x400 .
I want to conect an external supply with external drivers tb6600 4amps with to bigger motors 2.5amp
On the x and y axis
Do i need to change the config file for this to work?

To get it “working” in the most basic sense (that is, gantry moves to verify operation) no, but the short answer is: yes, you’ll need to alter the config file in one way or another after an extensive mechanical change like this.

No config file changes will really be needed if you’re using external stepper drivers and configure them to match the microstepping ratio of the onboard drivers in general, to test the motion. However, with the change to the new gantry you’ll likely need to alter acceleration settings, steps per mm, potentially some endstop settings, and likely a slew of other stuff that goes along with such an extensive motion control change.

We have another forum member who recently performed a similar “conversion” (that turned out to be a full new build in the end). Read through the thread here for an idea of what’s necessary to make that kind of change.

Hi, thanks for the reply.
I know that i have to change accel and speeds
But i dont get any movement at all…
I was just testing the wiring and yes from the k40 nothing is left besides the mirrors, head and switches.
I can see the mktor is energized but no movement at all…
All step, dir and ena pins remain the same by using the original adapter for external drives from cohesion 3d mini?
Thanks

Yeah, if you have the external driver adapters from here:


then you should be in good shape to have things just work - can you post some pictures of your machine and wiring so we have a better idea of what’s going on?

Humm for now its a complete mess, but ill post some… :grimacing:

If you have the external stepper driver adaptors as loather pointed out, can you post good pictures of the C3d mini showing the adaptors mounted and wiring and photos of the stepper driver wiring that shows the input and output wiring of the driver. It would also be helpful to post your config file you are using. I have a Mini (with the adaptor for my ZTable) in a K40 also and the photos requested will show if they are mounted properly and wired properly. Loather is correct that if everything is wired no changes to the config should be required for basic movement, but that’s assuming everything was wired correctly.
I’m on my phone right now and it’s hard to pull up the article to link to it, but there is an article on the cohesion website that show exactly how to wire the adaptors properly.

Here it js sorry for the mess but i think for it will do. Green cable is the 5v to the cohesion board thanks

here is my cnfig file
config.txt (25.3 KB)

Thank you for the photos and from what I was able to see there was nothing glaring that looked like the problem. Hopefully someone else will also confirm that there was nothing missed.

Some more questions, What is your driver set at for current and steps (the dip switches) ? What is the voltage and current rating of the power supply plugged into the drivers?

When you power everything up and send a movement command to C3d do the motors make noise or vibrate/hum at all? What does the leds on the driver look like?

Are you also sure the coil 1 and coil 2 are wired correctly from the motor to the driver?

Ok thanks for the help.
Drivers are set to 2 amps and 16 microsteps.
Motor arent energized, whwn jogging in lightburn nothing happen in the motors.
Power supply is 24v 15 amps.
Ive read somewhere that to get external drives to work in the cohesin 3d MINI the firmware must be changed because of the enable is high and external drives need low signal. Something like this.
The lights on the driver are light up both red and green. I think they should change when they receive a pulse.

And the coil pair are good ive double checked it

This his were ive read about the active low and high signals.
See if it makes sense for you and if i should try the firmware.
Thanks

Here’s an older page that may help in showing the connections from a C3D Mini to External Stepper Drivers:

Hi all problem solved.
Tried different firmwares but no luck.
So i went back to original firmare, add the! O after the pins.
But the real problem was that i didnt had the limit switches connected to the board so no homing no movent…
Thanks all