C3d mini install on k40 laser


(Guy) #1

Machine: K40 laser

Board: C3d mini

Firmware: _Smoothie

Problem/ Question: after install and connecting to lightburn, the head jumps at home position. I reversed the y cable but it does the same thing.


(Chris Leitch) #2

Can you describe the problem a bit more? Jumps at home position? Reversing the y cable sounds like you’ve set the origin position wrong but there a few other issues it could possibly be.

Sounds like there is potential for a limit switch/sensor issue.

Do you have a video you could link?

What software are you running? LightBurn?


(Guy) #3

First of all thanks for your help.
I tried to attach a video but it says I can only attach graphics files (jpg, etc.)
I’m using LightBurn and it shows a “homing error”.
Bed size is set at 300x200mm.
I agree it sounds like a limit switch problem, but it seems to work ok with the M2 Nano board.
I checked the ribbon cable and it seems to be seated on both ends and I don’t see any issues with the cable.
It seems to go to the home position then jump down about 1/2" then back home. It does this continuously until I cut power. I didn’t change any default settings in LightBurn.


#4

Please provide a video so that we can better understand the issue.


(Guy) #5

When I try to upload the video it says I can only upload graphic files and text files.


#6

Correct, please upload to YouTube or another video service and share the link here.


(Guy) #7

C3D mini


(Guy) #8

did you get video?


#9

I’m not too sure what I just saw in the video. Why were the lights flashing on and off? Is it possible you have an electrical issue?


(Guy) #10

I found the issue. Even though it worked on the M2 Nano board, it had the issue of homing error with the c3d board. The problem was that the power supply was set to 230v instead of 115v. After I changed this it worked as expected.


#11

That would do it. In the other direction, it would cause a nice explosion.

Specifically for your COHESION3D MINI (anyone else reading this, no need to do this for the new LaserBoard) - you should isolate your board from the machine frame with nylon standoffs (not spacers), and get a separate 24v psu to power the board for better stability.