Brownouts? and Grounding with UPS

Machine: K40 - Upgraded to larger machine

Board: C3D Mini

Firmware: Smoothie with Cluster Firmware and GRBL-LPC

Problem/ Question: I have had this machine up and running for awhile. I’ve started to dabble in photo images and occasionally I get a disconnect in Smoothie or an Alarm 3 in GRBL-LPC. The job would just stop mid run. I can do a dry run without the laser enabled and everything is fine. If I turn on the laser, it will run for a bit and then stop (Sometimes it completes). Research led me to believe I am having brownout issues of sorts. Here’s what I’ve done so far.

I have upgraded to a dedicated power supply for the board. (First thing I did when I bought the board)
The board is mounted with nylon standoffs onto a acrylic backer.
Upgraded 6’ high quality USB cable with ferrules on each end. (Can’t go shorter due to laptop position)
Powered USB 3.0 Hub
Power save and USB power save all disabled on the laptop

My last change this week was to get a UPS for the board. The 24v PSU is the only thing plugged in. The UPS. The UPS and the accessories are all on the same house circuit (same wall plug).

Last night, a new issue came up. The machine continued to run, however the laser stopped firing. I stopped the job and tried to manually do a test fire with the button (not on LPSU). Nothing happened. I turned off and on the LPSU to try again. Nothing. I went downstairs to grab my multimeter to check continuity between my laser enable button and door interlock. Before I did that, I tried again and it fired from the test button. I was able to finish my job (not a photo), but this had me perplexed. I didn’t check the wires cause I didn’t want to jinx it.

Two questions:

  1. Is there anything else I can do for the brownout issue? I’m not sure it is fixed yet as I haven’t tried a photo again.

  2. Do I need to ground the C3D mini board to the chassis or something since my power is now going through a UPS? I replaced the stock K40 blue wire harness with a new one that goes over to the LPSU. This already has a ground to it. Could this be the cause of the no fire issue?

This is really perplexing.

Thanks for the help.

An update and a bump to try and get some suggestions.

I disabled all of the safety switches that were installed and I haven’t had the laser stop firing and continue to run.

The laser will still stop mid job and random times. Happens a lot with images. Happens sometimes with raster engraves.

I run Lightburn for all of it.

You can’t have both of these at once. Which one is it that you are running?

Please provide pictures of your board, machine, wiring, and a screenshot of your full LightBurn window.

The more you can show me, the easier I can find any suspect issues.

Currently running Smoothie, but I have also experienced the issue with GRBL-LPC. That’s why I put both down.

I will have to get pictures after Thanksgiving, but I have been doing some research and it looks like I might have created a Ground Loop inadvertently.

  • My board is running on it’s own power supply that goes to a UPS.
  • The LPSU has it’s own dedicated cord.
  • All my accessories run off of a different dedicated cord that has switched outlets on the back of the case. The idea was for me to be able to power the LPSU and accessories from a different circuit if need be.

Where I think I went wrong is the grounds for the case, the LPSU, and all the accessories are connected on one bus bar. This bus bar is connected to both of the incoming power plugs. This effectively means that the ground is in one big loop inside my case. I will isolate the LPSU ground and case ground from the accessory plug and see if that solves the issue.

Does this line of thinking track?

I have isolated the LPSU ground, added an EMI filter and it still ends up stopping. Currently running Smoothie clustered. I have the machine set to home on startup. The machine doesn’t home after it stops moving every time, sometimes it just sits there. I get roughly 3 minutes into the job and it stops. It will run all day long if I leave the enable laser button off.

I was able to complete a small 3 minute job, but Lightburn continued to say 99% after it had completed.

Not sure what to do from here.

Something new… The laser stopped firing but continued to move. I stopped the job, checked my arm switch for continuity and it was fine, but the test fire button wouldn’t fire the laser. I wiggled the wire a bit and it fired. I fired it again and the laser homed itself.

Am I getting noise from the LPSU to the board through the cord? Thinking that was the cause, I moved some wires around and got the high voltage wire up out of the way from any other cables. I disconnected the connector and when I reconnect, the board reset and homed.

Tried to do a 5 minute burn and I can’t get much further than about 30 seconds before it rehomes. I can run the job without the laser enabled and it completes.

Are you using metal or nylon standoffs to attach the board to the machine? Try and make sure it’s as isolated as possible (use nylon).

If there’s a ground lug on your laser, connect it to a piece of #10AWG (6.0mm^2) wire and zip tie it to the laser power input cable. Terminate it to something that’s actually grounded (like the metal junction box or the outlet’s faceplate mounting screw [in the US these places should be grounded, by code - not sure about other localities]).

Verify your outlet is actually grounded. You may need to enlist the help of an electrician here.

The inside of a laser is a surprisingly hostile RF and electrical environment. Anything you can do to help shield and isolate components will help.

Good luck …

Oh, and keep the high voltage wire as far away as possible from any of the low voltage wires. Make sure the connections at the tube are good too - even a small amount of arcing from the HVPS to the laser tube electrodes will cause an enormous amount of EMI inside the laser chassis.

The board is screwed to an acrylic sheet. Completely isolated. Outlet is grounded correctly. Checked that all out and Ohmed it out with .2 to .5 resistance. The only low voltage that the HV wire is near is to my temp sensor. No arcing that I can tell. Very little metal involved. This is very perplexing. Also the machine ran fine previously. The only thing that has changed would be the UPS for the board, the EMI for the LPSU and rerouting the ground loop that I had caused. Is all of this signs of a LPSU going out?

My Layzor

Stock K40 LPSU

C3D Mini

EMI Filter going to LPSU

HV Wire - its near the incoming power and power going out of the case for exhaust.

Barrel Connector for the Laser Arm Button - Good continuity from one end to the other

Link to Video showing disconnect