Board Not Firing Laser

Just to chime in, I have the EXACT same problem as far as I can tell. I’ve tried the advice in all sorts of other threads with the laser head moves, fires manually, but won’t fire when running the software, red light on laserboard turns on.

I also have the exact same wiring setup with the 4 blue wires. It has a 24v/GND/5V/Signal terminals.

Sorry for speaking for you Tom! I was almost about to make a post on this exact topic.

Hi Tony,

Welcome to the forum! Congrats on your first post.

I’m moving this over to a new topic because it’s better not to confuse things with multiple threads in the same place.


Hey Chris,

Sorry about that. So here is what is going on.

  • Laser fires just fine using the test button on both the panel and LPSU
  • When I send some g-code lines in Lightburn such as G1 X10 S0.8 F600, the laser head moves, but nothing fires. The red “Laser Fire Status” LED also lights up
  • When I send any job to Lightburn it runs the job just fine, just no laser
  • I have the potentiometer on the panel set to 15mA
  • Played around with different power settings in Lightburn
  • Tried to fire with the GLCD plugged in and that doesn’t work either, but otherwise it connects and I can jog the machine around
  • One thing I didn’t try is changing the laser_module_pwm_period 200 to 400

Like you mentioned in the other thread, I have a feeling it has something to do with that white connector with the blue cables and the 24v supply. But I’ll let the expert chime in on that! :slight_smile:

LMK if there is anything else I can try or info to provide.

Here are some pics:

Several things to check please:

If you remove the large power plug with the blue cables from the C3D, and touch the L to the Gnd wire within that plug (use a short section of random wire to do this), does the laser fire?

If yes, now put the plug back into the board and make sure that the blue cables are fully pushed into the plug. They like to get loose and not make contact. And yes, I do see the hot glue they put over them :slight_smile:

Hey Chris,

Thanks for getting back to me.

  1. Yes the laser fires. I actually had previously tried this to make sure everything was working when I thought the LPSU may have been the issue.

  2. So I ended up removing the hot glue, “re-seating” the cables in the plug to make them fit better, tested them with the factory board (worked), and then re-glued them while applying some force to the cables to make sure they didn’t lift out when I was gluing.

Sad to say, same problem. Any other thoughts? If the laser wasn’t working with the factory board, I’d say we could pin it down to something else in the laser, but it is only an issue with the laserboard installed. Really hoping to get this working!

Problem figured out. Sort of a shitty conclusion.

When I was reinstalling the board I noticed some blackness on the underside of the board near the power plug. And yeah, the optocoupler between the laser gnd & laser fire is all burned up. I de-soldered it to see if it is salvageable. Looks like the ground trace is toast, but the laser fire is hanging on.

Any suggestions for me Chris?

In these pictures it appears that the large power plug with the blue wires, on the LPSU side, is plugged in shifted one pin to the left.

By my logic this would have created a reverse polarity condition and fed a positive high voltage (24v) to the optoisolator in question and ground. Not good.

Can you meter the the board?

Test instructions:

Please and check continuity (if short exists) with the board powered off. Have the SD Card removed from the board entirely and no cables connected to it.

In this diagram I show:

  • Ground (Gnd) with Black Square
  • VMOT Rail with Red Square
  • 5v with the Green Square. Touch it with the probe from the right so you do not touch any other pin, and be careful not to touch the SD card casing.
  • 3.3v with the Orange Squares - either on the SERIAL Header pin #2 from the left, or the head of the AMS1117 component - whichever you can access easier.

Set the meter to continuity mode to check for shorts at these 3 locations:

5v - GND
3.3v - GND

If there is a short between any of these 3 rails please let me know and do not proceed.

If there is no short, please plug the power brick into the board, observe if any LEDs turn on, and do the following voltage measurements:

With the board powered on, and your multimeter in voltage measurement mode (mine has maximums of 2, 20, 200v and I choose the 200v mode for this) please place and keep the negative probe on Ground.

Place the positive probe on VMOT. You should see a steady 24v.
Place the positive probe on 5v. You should see a steady 5v.
Place the positive probe on 3.3v. You should see a steady 3.3v

For each of those, please tell me what happens.

Thanks for the clear instructions.

No continuity between any of those spots on the board.

Do you think replacing that component that burned out would do the trick?

The 2nd half of the test instructions:

Whoops my bad.

The LEDs seem to all turn on just fine and all the measurements check out and remain steady.

Here is a quick video of the LEDs, sorry a bit shaky.

Ok, so the board is generally working aside from that problem area with the opto?

Hook up the motors and switches and try jogging and homing with it again. If you do that G1 line again, do you still get the red laser fire status LED turning on?

Based on all those tests, I guess so.

I will have to give it a try tomorrow when I have some time to give it a try.

Question: Should the laser engage switch be turned on when I run the G1 line, or just leave the laser engage switch off and just run the line to see if I get the LED?

Hey Chris,

Just went ahead and re-hooked the board up. It jogs around fine and homes, connected right to Lightburn. I ran the G1 line a handful of times and same result, laser moves without firing. I’ve been using the laser cutter just fine for the past few days with the stock board and K40 Whisperer just FYI.

One thing I just noticed is that I have a jumper on two pins that I don’t see on the pictures of the boards you’ve uploaded. No clue if it matters, just throwing out more ideas.

So you know, Chris and I are 2 different people.

Just run the G1 line to see if you get the red laser fire status LED.

Sorry about that.

I ran the G1 line and got the red laser firing LED.

You should consider yourself fortunate that you ran 24v thru a 5v part and managed to only kill that part and not the rest of the board.

I will also be taking the time to pat myself on the head for implementing such precautions on the board.

You can try to replace the opto, it is LTV-217-G by LITE-ON. Note that I am not sure if the pads and nearby trace survived. Check them with a meter for continuity.

Alternatively, you might try to get an opto module like so: and drive it from the 5v output header called “Alternate PWM Out”.

1 Like

Glad you designed it the way you did!

I ordered a replacement, got it today, and re-soldered it in there. The Pad+Trace that connected to the ground terminal was toast, so I just put a small wire in place. Getting continuity on the meter and everything seems good to go.

I’ll test it out tomorrow and hopefully, we’ll have success.

1 Like

Success! Everything seems to be working!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.