Board not firing laser (Previously titled with humor: Need the fire department)

Machine: Chinese K40 (upgraded???)

Board: Original board was the Nano; Replaced with Cohesion3D

Firmware: _Smoothie with latest firmware

Problem/ Question:


So, I’ve been battling this for 3 days now and am feeling REAL sorry for having purchased this board! I need the “fire department” to get my fire going, NOT put it out! I enjoy converting images to laser engravings and was looking forward to getting more realistic half-tones and such. My Nano board worked (works) just fine but, couldn’t get the type of results I was looking for.
With the Cohesion, I’ve gone through the whole PWM thing, tweeked the config file, updated firmware, uninstalled/reinstalled Lightburn, and cruised this and numerous other sites looking for an answer.
I’m a noobie and I just want to “make stuff”. I’m NOT an engineer, electrician, code jockey or designer. Just an old guy with big freakin’ hands, happy to be able to get stuff installed in the first place!
The attached pics represent the original Nano board (hooked up) as well as a few Cohesion3D pics, also hooked up. And a shot of my “control board” showing it set to 10MA max. Try as I might, no results for a burn. Test files sent through, go through all the X/Y motions correctly but no fire. Test fire on control board works wonderfully. The LED’s are blinking and/or steady where they’re supposed to be. Red LED in upper left corner comes “on” when I manually put a command into the console! Running Smoothie… I think someone is just playing with me here… :frowning: I sincerely had zero issues with the Nano board functionally. Just wanted better… PLEASE help!
Thanks!

Any chance we can look at your lightburn settings? What percent power is your cut set to?

Try running these commands from the console in lightburn. See if you get any output please. This is for tuning pwm but can also be used just as an example of commands to run some burn lines

What power do you have set in the laser? I ran into the same issue when first using board. Had power set to zero. Duh!

I’ll get the LB setting when I’m back in front of the machine. Which page specifically would you need? My Max output is set to 10mA, per my MA meter. I’ve tried that command and numerous others without any luck at getting any fire at all. Like I said, been messing with this for about 3+ days now. I even tried a different USB cable, though it’s an older one. Heading out right now to get a new, heavier duty one, just to try and solve or eliminate that part of the equation. Thanks guys!


Not sure if this is the exact screenshot you want/need??? Also, got new USB cable. No difference. Plus, went back to “Troubleshooting 101” and sanded off any paint left on the chassis ground.
Thanks!

I also went to this thread: K-40 New Cohesion3D LaserBoard laser will not fire with software .
From that, I pulled the K40 plug out of the C3D board and tried the jumper L to Gnd with nothing happening at all.
I have things which I need to get done for a few folks. Thought the C3D would make it better. Just going back to my Nano board and Inkscape/K40 Whisperer.

Aaron…Heard so many good things about you and the help you provide. Can I assume we’ve hit the proverbial brick wall on this one?
FWIW, I re-installed my stock Nano board and everything works as designed. If you’re done with this thread, let me know. Thanks.

?

I think you may have me confused with someone else. I’m fairly new to this as well…

So sorry! I thought they said it was an “Aaron”. My apologies!

have you tried to change the pwm value as David linked? just curious

Oh my, yes! Copied over the whole thing to a notepad and “copy/pasted” one after another. Laser head would move as commanded but, no fire. :frowning: Frustrating, to say the least. Tnx for checking, all the same!

So you tried changing the pwm value to 400 and nothing happened? Not talking about the gcode for movement testing, but editing the config.txt

That was one of the first things I did. There’s a good You-Tube video on setting up the C3D and that was indeed on his list of “to-do’s”, so I did! :slight_smile:

If you have a multimeter I can walk you through a few simple tests, otherwise just fill out our contact form on the website with your order #, shipping address, and reference this forum topic link, and we’ll arrange to replace the board.

Hi Ray. I “sort of” have a multi-meter; Lent it to a friend about a month ago and haven’t seen it since! I’ll try the replacement route and see if I have better luck. I swear, I read and checked every video on the installation and had everything down to the “T”! Spent a number of years doing PC hardware trouble-shooting/repair so, it’s not like I’m squeamish about digging in! Thanks much. I’ll get the info out. Appreciate it!

Ok, real quick then, just make sure the contacts on the large power plug are pushed into the board connector all the way. They have a tendency of getting loose.

Then run the G1 X10 S0.8 F600 command to try to move the head while firing the laser.

OK. I’ll give it a try when I’m back in front of the machine.Will need to swap out the Nano board again. And yeah, I made certain that all the connections are solid and, even re-seated the other two connections. I’ll let you know what happens with the command you gave me. Thank you!

Hey Ray. OK, back at the machine. Swapped in the C3D, double and triple checked connections and all appear to be ok. Ran the command you forwarded in the console and, just like before, head moves but no fire. The red LED in upper left corner lights up as expected but nothing at the head. :frowning:

Replacement board shipped today and you should have tracking info in email. Hang on to the board you have now, get the new board installed first, and I’ll get back to you later with info on how to pack it and return the old one. Our new shipping system should let me create a return shipping label in some easier fashion, I’ll have to play with it.

1 Like