Board apparently failed

Purchased a Cohesion3D board about 2 months ago, replaced the nano board that came with the laser.

Running smoothie

Yesterday powered the machine up and everything was normal, except it wouldn’t home, move or respond to lightburn. Looking in the machine I only see one red light on the 3D board, there are usually several flickering.

I pressed the reset button but no change. I powered everything off and back on but no change.

It appears that the board has failed, or I need some more troubleshooting.

P

James, I also have the same issue, replaced nano board with cohesion 3D board and 2 days ago I got a message that the machine was busy or paused and neither are true. Please let me know if you here anything. Thanks Dave e-mail- fxwg81@bellsouth.net

My problem is a little different, perhaps. I had the board working for weeks. It ran day after day, until it didn’t. So far, I wrote to “customer service” and the forum and have not been contacted by anyone. My board was only 2 months old. If that is the life of the board, I need to find a different board.

P

First, please provide pictures of your board, machine, and wiring as it was with the C3D installed.

Next, can you disconnect all wires from the C3D and try to power it up?

Photo of board

Yes, I disconnected everything and tried to power the board and had the same results. Only the red power LED none of the other LEDs ever light.

P

Have you tried taking the SD card out and putting it in your PC to see if it’s okay? The Smoothie firmware reads the config file from the SD card when it boots, so if the card has an error then the boot process won’t be able to complete.

Several things:

  1. I removed the board from all power for at least 5 hours (it was overnight).
  2. Recheck all wiring, no errors.
  3. Reinstall card with only the card power supply attached.
  4. Plug in the power.

At this point all the lights on the card came back on in a normal manner.

  1. Unplugged the power supply.
  2. Reconnect all wiring, steppers, laser power plug.
  3. Plug in power supply for the card. Try and not act surprised when the gantry homed. I am not certain that has ever happened without the laser powered.
  4. Plug in USB cable from computer. Power up LightBurn.
  5. Verified that the software communicates with the card and controls the laser properly. (As good as the Mophorn will allow)
  6. Sit here scratching my head as how the card fixed itself. I have been a computer technician since they started using bit sliced processors with magnetic core memory. Worked as an engineer for 25 plus years. I never have seen such a dead card reset itself and work
  7. I have now ran the ‘healed’ card for more than 6 hours of run time. At the very beginning there was an anomaly, but powering everything off and back on in a more realistic sequence seems to have fixed it.

I hope someone else can benefit from the experience.

Pete

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.