Back Again! X-Axis loosing steps when connected to external driver

Machine: Chinese Laser

Board: Cohesion3D LaserBoard

Firmware: Smoothie

Problem/ Question:
X axis loosing steps when controlled by external driver.
I first posted this issue last year and cause of it never determined.
To recap:
-X axis looses steps when connected to external driver
-X axis is accurate when connected directly to LaserBoard
-All hardware is BRAND NEW purchased directly from Cohesion.
-Even purchased a second LaserBoard for testing, with exact same results.
-Tested current settings 0.5A, 1.0A and 2.0, consistently loosing steps with any of these settings.
-Verified that Im getting 24V to drivers
-Worth mentioning that the Y-axis or Rotary Unit have NO issues running from external driver
-Swapped around all wiring from Laserboard to Drivers.
-Accelerations reduced, config file attached.

CAN SOMEONE PLEASE HELP SHED SOME LIGHT ON THIS??? I just don’t get it and its extremely frustrating. Not to mention wasting money on replacement boards, unnecessarily.

config.txt (28.4 KB)



Have you double-checked all the connections going from the laserboard to the external driver? It could be that there’s a loose wire either in the JST connector or the driver.

Try swapping the drivers for X and Y and see if you get the same result. If the problem follows the driver, post results and we’ll work on some next steps.

Hi Loather, nice hearing from you again.
Yes I’ve checked every connection and done continuity checks and purchased new drivers and a new Laserboard… it’s not loose wiring or faulty hardware.

Additionally I’ve also tried 1/8 and 1/32 micro stepping with exact same result. also tried independently powering that 1 driver with the power supply that came with my new laserboard.

Whatever the issue is its totally repeatable and consistent in faulty output.

What setting(s) in the config file ONLY apply to the external driver?

There are settings that apply to both the internal and external drivers, but nothing that applies to just the external drivers. The only configuration parameter that applies to only the internal driver (per axis) is the _current setting - this would be set on the external driver itself using the dip switches. There are also some config options at the end of the file that deal with the internal drivers, but they’re largely irrelevant to your problem :frowning:

Here’s a breakdown of what the settings affect (look at the end of the comment). The same is true for all axes. (values taken from a stock config file)

alpha_steps_per_mm            18.25        # may be steps per degree for example - BOTH
alpha_step_pin                2.0          # Pin for alpha stepper step signal - BOTH
alpha_dir_pin                 0.5          # Pin for alpha stepper direction - BOTH
alpha_en_pin                  0.4          # Pin for alpha enable pin - BOTH
alpha_current                 1.0          # X stepper motor current - INTERNAL
alpha_max_rate                24000.0      # mm/min - BOTH
alpha_acceleration            1500         # mm/sec² - BOTH

I’m familiar with some of those settings, but as you said they are not relevant to my particular issue. I’m really hoping someone has come across this in the past and can shed some light here.
There has to be something we’re missing.

Some DSP stepper drivers have a “step filter” or “normalizer” setting that can cause odd behavior, but the drivers in the units you bought from the Cohesion3D store are basic digital drives that don’t support any of that nonsense.

I know you said you bought new drivers and a new laserboard, but did you try a new breakout cable between the board and the driver?

I’ve swapped those around with Y axis and Rotary drivers. I’ve also tried shielding in the odd case that there was some kind of RF interference.

I’ll be installing a stepper on the Z axis this weekend, will double and triple check all connections at that time. Please do provide additional feedback if you think of anything additional I should be checking.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.