Amp meter needle moves but there's almost no power from the laser

Machine: K40 analog version white/blue

Board: C3D Mini

Firmware: Smoothie

Problem/ Question:


I recently got a used k40 (best I can tell it’s from 2017, analog setup, white and blue) It came with a Cohesion3D Mini LaserBoard.

I have the Cohesion3D board powered by a separate 24v power supply. I’ve watched countless hours of videos and read all I could find on the forums about it to make sure I’ve hooked up everything correctly.

I run LightBurn 1.2.01 and everything works except that when I press “start” on a job the head moves and (interestingly) the Amp meter needle moves, but there’s almost NO POWER (low to no intensity) coming out of the laser no matter what power settings I use in LightBurn.

I have the machine’s potentiometer set to 11 Amps.

When I press the fire test button everything works great, the beam is focused and centered, aligned. (That makes me think the LPSU and laser tube are ok.)

I’ve tried doing PWM calibration and everything works with the standard setting of 200 microseconds period. The tube fires exactly like it’s supposed to.

I’ve gone over the “config” file and confirmed that I have the right settings according to a bunch of other people on the forums. I’ve tried multiple different versions of the firmware (old and new) and this issue persists.

Seems like the S-Value is the culprit.

I have the digital LCD that comes with Cohesion3D and there I can see that the S value is set to 0 after every code command from LightBurn.

I tried running manual commands in the Console in LightBurn and when I do that and specify the S value of my choosing everything is good.

I run a Win10 laptop and have installed the regular (Gcode only version) of LightBurn.

This makes me think that the problem is something to do with the way LightBurn formulates the Gcode commands before sending them to the Cohesion3D board.

This is the G code I get when I run a job of engraving a simple rectangle in the middle of the laser bed.

Any ideas are greatly appreciated!

I’m out of ideas and really hope someone would be able to help.

TLDR: k40 C3D mini laser fires fine except when LightBurn sends Gcode commands S goes to zero. WTF lol

make sure your laser type in lightburn is set to smoothie

It’s set to Smoothie. I also tried my luck with running GRBL and that has the exact same issue. I’m starting to think that the C3D Mini is the problem. Today I tried to measure the Voltage coming out of pin 2.5 and it was 0V while running a job. Does that mean the Board is toast?

I also tried connecting the L wire from the PSU directly to ground and the laser fired. I think this means the PSU is ok.

Also weirdly the control panel “test fire button” fires but when I try the “test” button on the PSU it does not fire. Not sure what that means.

Just tried to measure the L (screw terminal 4) and G (screw terminal 2) output from the C3D Mini and got 0.12 V when I ran G1 X10 S0.8 F600

manually and the laser was supposed to fire.

Does that mean that the L217 optocoupler is bad? I saw that case here.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.