Alarm 3 in Lightburn in the middle of job


(Rob) #1

Machine: K40

Board: C3D Laserboard

Firmware: GRBL-LPC

Problem/ Question: I can engrave and cut vector images all day long, but when I try to engrave a picture in Lightburn the job stops about 30% in and gives me an Alarm 3. My laser is nowhere near the endstops, I have the laserboard mounted to the K40 with nylon screws, nylon spacers and nylon washers. There is absolutely no way it is grounding to the chassis of the K40.

I literally engraved and cut 12 projects in a row yesterday with absolutely no issue whatsoever. I then tried to engrave a photo. The first one came out just fine but I had cut against the grain by mistake and decided to flip the material over and engrave with the grain. about 30% in the job stopped.

I shut everything down for about 20 minutes and then tried it again. Same issue. No settings were changed. The only thing I did was flip the coaster over.

I posted this in the Lightburn forum and they said it was a problem with the board and not the software. Any help would be greatly appreciated.


(Rob) #2

I should also mention that this happened 6 times on Thursday. I was not able to complete a single image engrave.


(Jamie Richards) #3

Do you have any appliances or motors kicking on the same circuit?

https://forum.cohesion3d.com/t/usb-dropouts-brownouts/667


(Rob) #4

Hi Jamie,

I do have the fan for the exhaust and the water pump connected to the same power strip. So to be clear, I have a grounded power strip with the following attached: Fan, Pump, K40 and the Laserboard.

You think I should have a separate power source for the Laserboard?

I tried the link but it gave me this message:

I’m logged in, so I am not sure why I would have restricted access.


(Jamie Richards) #5

You may want to try that.

That guide is about to be published, I forgot it was still under drafts.
@Starla


(Jamie Richards) #6

(Rob) #7

I guess I am confused about why I would only have issues with images. I cut all of the following yesterday and made multiple changes to my original design along the way until I got a finished product I was happy with. The laser didn’t act up or “brownout” once during all 14 (sorry 17) of these engravings.

All of this was done on the same K40 and the same configuration as the image. These are 5 X 7" pieces whereas the image I showed you was about 70 X 70mm on a birch coaster. These were engraved and then cut out of 8" X 8" 3mm birch. Same material, just larger work area.

If I am only experiencing an issue when engraving images, to me anyway, that would be a software issue, but Lightburn sent me here saying it was certainly not their software causing the issue.

@raykholo was monitoring that discussion and asked me to bring it here as well, so far, I have not heard from him.

Anyway, here are all the attempts made with vector art and text that I made right after the failed image attempt. All of these finished 100% of the job. The only reason there are so many is because I was playing with temp and speed and ultimately changed the original design.




That stack on my desk was engraved on both the front and back sides in an effort to fine tune my design.


(Rob) #8

Thank you,

I will look at all of those setting tomorrow. I’m still puzzled as to why it only happens during image engraves???


(Jamie Richards) #9

Is it possible your computer is having problems sending that much data to the laser? You could try switching ports. Perhaps there’s a shared resource causing the hiccup.


#10

In short, this is usually a clean electrical power issue.

The LaserBoard is well isolated already - the guidance that you found regarding the nylon standoffs was meant for our previous board, but no harm…

LaserBoard’s power brick should be plugged in to its own outlet, and if it disconnects then you are having either unclean power from that outlet or an inductive load is causing a brownout on that AC circuit in your house.

Also, are you using a high quality usb cable?

Finally, do you have usb power saving on your computer fully disabled?

I am on my phone at an airport so I mostly skimmed, I will try to follow up when at computer, but that’s the standard guidance on this matter.


(Rob) #11

I took the brick off of the power strip I am using for the LPS, pump and fan. So far, it has worked without issue. I will be trying another image today as a test. I will also check the USB power saving mode is off on my PC.

I do have a good usb cable so I am confident that isn’t the issue. The thing that puzzled me the most was the fact that I was able to do quality, repeatable vector art 15 or 16 times in a row, but was unable to finish a single, small image.

I will look at the usb power saving and see if perhaps that was the issue. Otherwise, for now, I am satisfied that taking the brick off of the power strip has solved the problem.

I also read in another forum that the 24v and 5v leads from the LPS should be removed from the Laserboard as they do nothing and could potentially cause issues. Can you confirm that for me?


(Rob) #12

Ok, so I have my brick on a completely different circuit as the rest of the shop. I purchased a brand new USB cable this morning on my way in. I have all power saving options turned completely off on my PC.

I designed a small 30x30mm test square, moved the laser to the middle of the table so I was nowhere near any end stops. I hit start and it burned a line about 10mm long and then gave me an alarm 3. No power issues, no usb disconnects, no brown outs, completely separate circuits.

Alarm3

I am able to run the entire square with the laser powered off. Why would the laser be triggering a reset to the board? It seems to run just fine until it gives the signal to fire the laser. At that point it decides to do a reset?.?.?.?

Oh, and I just ran a different test. I pulled the stepper leads off of the board and ran the same program with just the laser firing. It worked perfectly. The issue only happens when I try to cut and move at the same time.


(Jamie Richards) #13

EMI from the LPSU. Everything is well grounded? The high voltage transformer may be putting out a dirtier than normal signal. If you turn the power way down, does it still have the same effect?


(Rob) #14

Hi Jamie,

Yes, it happens at all power levels. The LPS is well grounded.


(Jamie Richards) #15

Definitely sounds like EMI from a dirty LPSU. One thing you could try is to get some snap on ferrite cores for all the wires.


(Rob) #16

Ordered. I sure hope that’s the issue. Otherwise, I feel like I completely wasted $450 for the 2 controllers that were advertised as a direct replacement for the K40 m2 nano board.


(Rob) #17

I really appreciate your help, Jamie. I have licensed another copy of Lightburn on my Macbook Pro. I am going to take it to the shop in the morning and use a shorter USB cable. I am thinking that perhaps it is due to the length of my USB cable from my PC.

After isolating the brick from the rest of the K40 electronics, my stock K40 is working properly at the moment, but the modified laser is the one that is having the issue now. It is approximately 15 feet away from my PC.

Hopefully, the length of the cable is the cause of the problem and can be fixed with a shorter cable and my Macbook.

I will post an update as soon as I have one.


(Jamie Richards) #19

Cable length may have a lot to do with it. 15 feet seems kind of far for something this sensitive. I would try using another computer using a 6’ cord and see if the problem disappears. The longer the run, the more prone to interference it will have. Cohesion3D sells a cable known to work well with the controller.