Air assist installation


(Eamonn Burns ) #1

C3D / K40 / Lightburn

Out of interest anyone have any setups for configuring air assist for a hailea air pump (uk socket) with c3d/lb

Thanks :slight_smile:


(Chris Leitch) #2

It depends which C3D board you have…
If you have a look here:


You’ll see the connections for the LaserBoard and what they can control.


(Dave) #3

Setting mine up last night, I did not see any markings for polarity on the air assist connector.
My understanding is that this is an open-drain output with +24V on one pin and the open drain connection on the other pin, with flyback diode protection for relay coils.

I’m driving an SSR from this, in series with the hot lead to the 110V outlet for the air assist pump.

I should be ready to double-check wiring and power the system up for testing soon. It’s eating more wire than I would have expected, but so far it’s going smoothly.


#4

The + and - are written on both the top and bottom of the board in the air assist corner.


(Dave) #5

Ok, thanks! I didn’t think to look on the bottom. Combination of tiny print, old guy vision and late night installation got me.


(Joel Wedberg) #6

I have an issue…
Running C3D Mini at a K40 with Lightburn. So similary but a Mini instead.
I cant get understand how to connect my relay for the airpump.
Want it to be trigged by “Air Assist”-option.

Tested 2.4 and 2.6 but they will always give 24v, 5v and 5v no mather how.
Checked config-file and found

Switch module for fan control

switch.fan.enable false
switch.fan.input_on_command M106 #
switch.fan.input_off_command M107 #
switch.fan.output_pin 2.6 #
switch.fan.output_type pwm # pwm output settable with S parameter in the input_on_comand
#switch.fan.max_pwm 255 # set max pwm for the pin default is 255

Edited to

Switch module for fan control

switch.fan.enable true
switch.fan.input_on_command M106 #
switch.fan.input_off_command M107 #
switch.fan.output_pin 2.6 #
switch.fan.output_type digital # pwm output settable with S parameter in the input_on_comand
#switch.fan.max_pwm 255 # set max pwm for the pin default is 255

But it only resulted in computer and Lightburn can see the board, but doesnt do something.

Are so sick of the airpump running all the time


#7

Please post your full config file and pictures of your machine, board, and wiring so that I may fully understand your setup.

To post the config file here Please surround it with 3 backticks (that’s the key at the top left of your keyboard where the tilde is) like so:

```

paste your config file here

```

It will make the code be all nicely formatted like this
Line 2
I might be enjoying this var when (I say I am)

Alternatively, you may paste the config file to Pastebin, Dropbox, or Google Drive and provide the link here.


closed #8