3D mini won't flash firmware

Machine: K40

Board: 3D mini

Originally the board came with smoothie and over a year ago I flashed it to GRBL-LPC firmware which went fine but now I bought a rotary so I need to upgrade the firmware and it won’t flash. I put the firmware and config file on the sd card and put it in the board and when I turn on the board the L1 and play LED are on and do not change. When I connect up a USB cable and start LightBurn the console shows a message of Grbl 1.1 and an error 9. I have tried another sd card with the same results

Problem/ Question: Please provide a detailed description and pictures of your machine/ board/ wiring.

GRBL-LPC doesn’t run the LEDs on the board the same way that Smoothie does.

That sounds like it in normal operation mode.

Please provide some pictures of your board and wiring so I can see what version board it is exactly and what you have hooked up to it so that I can advise you how to proceed.

The problem is that I am trying to flash it with Smoothie and my understanding is that I need to put the smoothie firmware.bin and config.txt on the card and it should flash when its started up and will count in binary as it does but it doesn’t… I disconnected everything from the board but the power

When I first bought the board it had smoothie but I needed to raster engrave so I switched to Grbl and it works fine but I bought the rotary attachment so I need a new firmware for the extra axis. I bought the rotary to engrave some tumblers as a donation for a charity event this weekend but since it won’t flash the rotary is useless and so is the board if I can’t flash it and I won’t have the donation for the charity event.

To make it clear the problem is I CAN’T FLASH A NEW FIRMWARE. I’m extremely frustrated because that’s what I said in the first post and the only response has been that I should post a photo of how its connected and the the LED behavior is correct for Grbl which I need to replace and I posted a photo which is irrelevant because I now have the board out of the machine and only have power connected and even if it was still in the machine it works with the Grbl.

Up until the last year I was very active on various K40 forums and facebook forums and and often posted about the Cohesion 3D board and encouraging people to buy the board telling them what great board it is and how great the tech support is.

Now I’m extremely frustrated, I posted my problem on Dec 9th then Ray responded on the 11th saying it was normal behavior and to post a photo of how my board is connected up which is completely irrelevant since it works as connected but my problem is I can’t FLASH THE FIRMWARE TO USE THE BRAND NEW ROTARY I BOUGHT FROM HIM!

Getting frustrated and pissed off isn’t going to help the situation. Do as he asks - there’s a reason for it, be polite, and he’ll be able to help. Cohesion3d is a one-man show and as most small businesses are, he’s hugely busy this time of year.

As far as flashing firmware on the board goes:

Make sure it’s a clean SD card with no other files on it besides firmware.bin and config.txt. Format it FAT32 before using it if possible. Try a different card if that one doesn’t work. SD cards are fickle. I have a couple here that refuse to work in certain devices, work sporadically in others, and work perfectly in some.

When you flashed it to GRBL-LPC, what exactly did you do? Same process of putting the firmware.bin on the SD card, or did you use a serial flash method on the microcontroller?

Craig, I’m sorry to have kept you waiting in silence for nearly a week.

For the last few weeks, I have been trying to get through shipping and doing support on nearly double our typical order volume.

Unfortunately, as I sometimes forget, any response is better than a shiny comprehensive response, the latter being what I have been working on for you in my head for the last bit of time there.

The highlights of that response include:

  • I haven’t personally experienced it, but I have heard some users talk about how grbl-lpc can be “sticky” on the board.
  • Try disconnecting everything from the board (you did this, great!)
  • Try flashing the new firmware onto the board, try a different SD Card, format, etc…
  • Depending on how you are powering the board, and what the power supply on the other end of that picture is, you may need to try powering the board from a good power supply, or the USB cable.

This is the firmware file you want to use: Improved Raster Speed Firmware Update for Cohesion3D Boards!

The LEDs will do “flashing firmware” as shown here when it takes: Cohesion3D Board Indicator Status LEDs

Please let me know how this goes.


I can understand being frustrated, but it is just me trying to hold down the fort here and I’m trying to do that and get out with a tiny amount sanity at the end here. I am not trying to leave you hanging, I want to help, I just need a bit of breathing room.

I’ve tried several SD cards even one from the smoothie board in one of my 3D printers (which I upgraded from smoothie to marlin 2 weeks ago so I know its good but it doesn’t flash. The power supply is a dedicated 24 volt supply.

The silence was my main frustration.

And I have tried formatting the cards and no difference

If I connect everything back up it works with Grbl because after posting the problem I connected it back up and aligned my Lightburn camera it just won’t update to anything its stuck on Grbl 1.1f

I tried everything again and even downloaded those files again and nothing, its definitely stuck on Grbl.

I wonder if your bootloader got overwritten somehow. It’s the bootloader that reads the SD card and flashes the firmware based on what it sees. Without the bootloader the program written to the MCU will still operate, you just won’t be able to easily flash the firmware without a serial adapter. I’m not sure how to tell if the bootloader’s present or not (admittedly I have little experience with this particular microcontroller).

Ray, any thoughts?

I have a usb to ttl serial adapter

Ray, How can I program a new boot loader? I looked up doing it on a smoothie board and its not too difficult and I have a USB to ttl serial adapter. For a little background on me I’ve had my own computer repair business for 34 years and I started out doing component level repairs on Osborn and Kaypro computers back when CPM was the operating system of choice.

What program and files do I need?

There’s a link on the smoothieware site that goes through the process (vaguely) to do it.

http://smoothieware.org/flashing-the-bootloader

There’s a serial header below the graphic LCD connector next to the two FETs. As far as the ‘bootloader’ switch goes - I’m not sure where to connect this (or if it’s the same as the “PLAY” switch or whatever. The reset switch is the vertical mount reflex switch on the corner of the board.

In any case, the bootloader would have been flashed to the board before you got it. I’m honestly kind of surprised it may have been written over. Either way, I’d wait for Ray to weigh in before proceeding with this because there could be a simpler solution.

Before we go down this road, Craig, can you confirm that you have tried as I have asked with the using several memory cards and trying to power the board from both the PSU and from a USB port? Perhaps remove some of the green stepper driver modules from the board and try again. As far as I know this has been the solution for this issue most of the time, it might just take exploring some of those options.

It is also possible to use a 4 axis build of GRBL-LPC, here: https://embeddedtronicsblog.wordpress.com/2018/12/26/grbl-lpc-firmware-builds/

This one: https://www.dropbox.com/s/g8sjoni174ykze4/firmware_grbl-lpc_c3dmini_4axis.bin?dl=0

If not, I have our bootloader flashing instructions ready to send.

I have tried several different memory cards and I can’t power it from USB because I did have problems with disconnects originally so you told me what trace to cut to disable it but I can solder a jumper to put it back . I will first try removing the steeper modules today to see if it works and if not I’ll try powering it from the usb I’ll even try powering from the K40 supply. I have no problem trying anything first before going the route of reflashing the bootloader because although it might be the fastest route to get it going most people can’t do that so if we find another way to get it to flash that would be better.

I do want to go with smoothie because it is now faster and I like having a display.

Still won’t flash and I even tried the grbl from your link.

I did as you asked and tried the different powering and I removed all of the stepper drivers and have tried 4 different cards. Still won’t flash

I messaged Craig the flashing instructions.